Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155864 - anaconda kickstart fsck
Summary: anaconda kickstart fsck
Keywords:
Status: CLOSED DUPLICATE of bug 136051
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-25 00:57 UTC by W Agtail
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 19:50:10 UTC


Attachments (Terms of Use)
kickstart file (deleted)
2005-04-25 00:57 UTC, W Agtail
no flags Details
updated kickstart file - ks.cfg (deleted)
2005-04-26 21:08 UTC, W Agtail
no flags Details
/etc/mdadm.conf (deleted)
2005-04-27 18:25 UTC, W Agtail
no flags Details

Description W Agtail 2005-04-25 00:57:13 UTC
Description of problem:
I'm unable to catch all screen output.
System fails to reboot cleanly after building system via kickstart (ks.cfg).
Some of the screen output is:

mdadm: ARRAY line /dev/md3 has no identity information.
mdadm: only specify super-minor once, super-minor=2 ignored.
mdadm: ARRAY line /dev/md2 has no identity information.
mdadm: only specify super-minor once, super-minor=1 ignored.
mdadm: ARRAY line /dev/md1 has no identity information.
mdadm: no arrays found in config file
Checking filesystems
/dev/md3: clean, nn/nn files, nn/nn blocks
/dev/md2: clean, nn/nn files, nn/nn blocks
/dev/sys/tmp is mounted, e2fsck: Cannot continue, aborting.
/dev/sys/use is mounted, e2fsck: Cannot continue, aborting.
*** An error occured during the file system check.

System then drops to maintenance mode.
Pressing control-d reboots system and same messages appear.

If I then use the attched ks.cfg file and comment out
#logvol /usr --vgname=sys --size=8000 --name=usr --fstype=ext3
the above messages appear again.
Pressing control-d reboots system and same messages appear.

On entering maintenance mode and running:
mount -o remount,rw /
### NB: I now have access to commands under /usr re: commenting out /usr in ks.cfg.
vgdisplay
vgscan
### NB: there is no /proc/lvm dir !!
cd /proc
find . -name "*lvm*"    # maybe it moved in FC4?
find: WARNING: hard link count is wrong for ./1/task: this may be a bug in your
filesystem driver.

I then hit control-d, system reboots, complains with above mdadm errors, but
systems starts up cleanly.

Still no /proc/lvm dir and find still errors with above mentioned bug in your
filesystem driver error.

All sounds very nasty to me?
Any thoughts on this?

Version-Release number of selected component (if applicable):
FC4 test 2 ISO CD1

How reproducible:
every time.

Steps to Reproduce:
1. boot from FC4 test2 ISO CD1 - FC4-test2-x86_64-disc1.iso
2. with ks.cfg stored on compactflash card (internal USB media reader)
3. linux ks=hd:sda1/ks.cfg
  
Actual results:
see above.

Expected results:
a clean system after running kickstart.

Additional info:
CPU: Althon 64
Disks: 2 x SATA1 - sata_sil module
USB MediaReader: compactflash card with ks.cfg

Would also be nice if FC4 could include the following:
Marvell Yukon 88E8053 8.16 module - seems to work OK
from http://www.marvell.com

and RalinkRT2500 rt2500 1.1.0-b2 module from:
http://sourceforge.net/projects/rt2400/

and anaconda being able to detect a LG L1730P 17" LCD monitor :)

Comment 1 W Agtail 2005-04-25 00:57:14 UTC
Created attachment 113620 [details]
kickstart file

Comment 2 W Agtail 2005-04-26 18:31:53 UTC
I have also noticed that /dev/LVMVolGroup/LVol device files do not get created.
e.g. /dev/sys/tmp

Comment 3 W Agtail 2005-04-26 21:08:46 UTC
Created attachment 113691 [details]
updated kickstart file - ks.cfg

Added:

logvol /tmp --vgname=sys --size=1024 --name=tmp --fstype=ext3
logvol /usr --vgname=sys --size=8000 --name=usr --fstype=ext3

#and:

%post
# this is required to create lvm devices under /mnt/sysimage/dev/VGroup/LVol
# e.g. /dev/sys/{tmp,usr}
vgscan

Comment 4 Jeremy Katz 2005-04-27 05:37:53 UTC
Can you provide /etc/mdadm.conf?

Comment 5 W Agtail 2005-04-27 18:25:38 UTC
Created attachment 113727 [details]
/etc/mdadm.conf

as request. /etc/mdadm.conf created during kickstart build.

Comment 7 Peter Jones 2005-05-19 19:50:10 UTC
I can't duplicate any of this in test3 except for the warnings regarding
mdadm.conf .  Those are already filed as another bug, so I'm closing this as a dupe.

*** This bug has been marked as a duplicate of 136051 ***


Note You need to log in before you can comment on or make changes to this bug.