Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155863 - Kernel 2.6.11-1.14 kills hpoj
Summary: Kernel 2.6.11-1.14 kills hpoj
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-25 00:31 UTC by P Jones
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-19 23:30:08 UTC


Attachments (Terms of Use)

Description P Jones 2005-04-25 00:31:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
Kernel 2.6.11-1.14 seems to make hpoj unable to see my OfficeJet 7110 which I have connected by USB. Running ptal-init setup results in output that looks like this:

Probe for USB-connected devices ([y]/n)?  y
Probing "%004%001"...
    No device found.
Probing "%003%001"...
    No device found.
Probing "%002%001"...
    No device found.
Probing "%001%001"...
    No device found.

Things work as they are supposed to if I switch back to kernel 2.6.10-1.770.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14

How reproducible:
Always

Steps to Reproduce:
1. Boot using kernel 2.6.10-1.770 or earlier.
2. Set up hpoj printer.
3. Reboot, select kernel 2.6.11-1.14.
4. hpoj printer is gone, ptal-init setup outputs as above.

Additional info:

Comment 1 Dave Jones 2005-07-15 20:18:32 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 P Jones 2005-07-19 23:30:08 UTC
I have moved on to FC4, and am no longer having the problem. In fact, the FC3
kernel that came after Kernel 2.6.11-1.14 fixed the problem for me, as I recall.
I've changed the status to RESOLVED CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.