Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155853 - garbage string from Combo.getText() causes NPE creating new run configuration
Summary: garbage string from Combo.getText() causes NPE creating new run configuration
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
: 152314 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-24 19:46 UTC by Andrew Overholt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-03 17:33:47 UTC


Attachments (Terms of Use)
log with failure information (deleted)
2005-04-24 19:46 UTC, Andrew Overholt
no flags Details
swt app to make a Combo box (deleted)
2005-04-28 21:18 UTC, Ben Konrath
no flags Details
patch to work around the NPE (deleted)
2005-04-29 20:51 UTC, Ben Konrath
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Eclipse Project 90946 None None None Never

Description Andrew Overholt 2005-04-24 19:46:35 UTC
Description of problem:
Error creating new "Java Application" run configuration.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M6.10

How reproducible:
Always.

Steps to Reproduce:
1. Create a simple Java Project with a Hello World example
2. Hit the run button
3. Double-click "Java Application"
  
Actual results:


Expected results:
No error.  New run configuration.

Additional info:
Double-clicking "Java Application" after the failure works.
None of this does not happen with Sun's JVM.

Comment 1 Andrew Overholt 2005-04-24 19:46:35 UTC
Created attachment 113616 [details]
log with failure information

Comment 2 Andrew Overholt 2005-04-26 16:10:02 UTC
I don't get this anymore with gcc*-4.0.0-1 and
eclipse-platform-3.1.0_fc-0.M6.11.  Closing.

Comment 3 Ben Konrath 2005-04-26 21:20:39 UTC
This is still happening with "Eclipse Application" - same stack trace.

Comment 4 Ben Konrath 2005-04-28 17:44:03 UTC
Archiving what I've got so far ... 

Combo.getText() in PerpectivesTab.updateConfigFromCombo() is returning a string
with garbage at the end (Ω) when run with gij. This causes the NPE because it's
not recognized as a string. Investigating this further it seems as though the
string is getting corrupted somewhere.

I made a stand-alone test for Combo.getText() and the string is not corrupt with
both VMs. However, I did notice that OS.strlen() is getting called an extra time
with gij. I'm not sure if this is related but I'll going to keep digging.

Comment 5 Ben Konrath 2005-04-28 21:10:17 UTC
*** Bug 152314 has been marked as a duplicate of this bug. ***

Comment 6 Ben Konrath 2005-04-28 21:17:24 UTC
The small app actually does have the corrupted string, just not all the time.
When the string is corrupted I also see:

(<unknown>:24571): Pango-WARNING **: Invalid UTF-8 string passed to
pango_layout_set_text()

Comment 7 Ben Konrath 2005-04-28 21:18:40 UTC
Created attachment 113812 [details]
swt app to make a Combo box

Comment 8 Ben Konrath 2005-04-29 20:51:22 UTC
Created attachment 113876 [details]
patch to work around the NPE

I think it might be a good idea to work around NPE temporarily until the cause
of the corrupt string is found. Andrew, what do you think?

Comment 9 Andrew Overholt 2005-04-29 21:25:37 UTC
I think that's a good plan for the short term.

Comment 10 Ben Konrath 2005-04-30 20:49:20 UTC
Ok, that patch will be in 3.1.0_fc-0.M6.13

Comment 11 Andrew Overholt 2005-05-01 16:43:26 UTC
Verified in 3.1.0_fc-0.M6.13.

Ben, I'll leave it up to you to close this bug or leave it open as you see fit.

Comment 12 Ben Konrath 2005-05-02 04:37:10 UTC
Hey Andrew,

Billy pointed me to the actual cause of the problem (see the upstream bug listed
below). I'm going put the proper fix into a new version so we shouldn't put
3.1.0_fc-0.M6.13 into FC4.

Comment 13 Ben Konrath 2005-05-02 21:40:37 UTC
Ok, I removed my patch and added the upstream fix for 3.1.0_fc-0.M6.14. Andrew,
can you verify this fix and close the bug if it works. Thanks, Ben

Comment 14 Andrew Overholt 2005-05-03 17:33:47 UTC
This works for me.  Closing.


Note You need to log in before you can comment on or make changes to this bug.