Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155852 - Various namelist ICE patches for gfortran from gcc bugzilla
Summary: Various namelist ICE patches for gfortran from gcc bugzilla
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc4
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-24 18:22 UTC by Mark Williamson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.0.0-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-02 09:50:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 19467 None None None Never

Description Mark Williamson 2005-04-24 18:22:47 UTC
Description of problem:
I've recently encountered an ICE when compiling some fortran code with
gcc-4.0.0-0.42. I submitted a bug report to the gcc bugzilla database:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=21192

This turned out to be a duplicate of:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=19467

Further reading of this bug idicated that it and some closely linked gfortran
namelist bugs:

	PR fortran/17472
	PR fortran/18209
	PR fortran/18396
	PR fortran/19467
	PR fortran/19657

had recently been resolved.

These have gone into the 4.1 branch under the term "Paul's recent namelist
patch", and would also be added to the 4.0.1 branch when it reopened.

My CVS skills are quite poor and I've not been able to locate "Paul's recent
namelist patch"(es) as referred to in the gcc bugzilla report yet, but would it
be possible to incorporate this patch into the the current gcc .src.rpm?

Comment 1 Mark Williamson 2005-04-24 20:29:52 UTC
Found changes at:

 http://gcc.gnu.org/ml/fortran/2005-04/msg00008.html

Comment 2 Jakub Jelinek 2005-05-02 09:50:24 UTC
Backported in gcc-4.0.0-2.


Note You need to log in before you can comment on or make changes to this bug.