Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155850 - openssl tests fail in FC4
Summary: openssl tests fail in FC4
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-24 17:21 UTC by Bernard Johnson
Modified: 2013-07-03 03:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 03:21:11 UTC


Attachments (Terms of Use)

Description Bernard Johnson 2005-04-24 17:21:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
Openssl functionality is now enabled.  The corresponding tests associated with it should be run as well.  Without running the tests, there is no way to know if the openssl functionality is working correctly or not.

Version-Release number of selected component (if applicable):
mysql-4.1.11-2

How reproducible:
Always

Steps to Reproduce:
1. Rebuild rpm and watch for tests.
2. Observe:
<snip>
openssl_1                      [ skipped ]
<snip>
rpl_openssl                    [ skipped ]
<snip>
3.
  

Actual Results:  <snip>
openssl_1                      [ skipped ]
<snip>
rpl_openssl                    [ skipped ]
<snip>

Expected Results:  These tests should be run since openssl is now enabled in the build.

Additional info:

Although it doesn't cause a loss of functionality, there is no integrity to the ssl portion of the build without a test.

Comment 1 Tom Lane 2005-04-25 07:33:31 UTC
[ digs around... ]  Hmm, you'd think that the mysql makefiles would be designed to test optional 
features if configured in, wouldn't you?  But nooooo ... "make test" doesn't run *any* optional tests.

Thanks for the heads-up.  I'll see about patching around this bit of brain damage.

Comment 2 Tom Lane 2005-05-09 19:05:55 UTC
Well, sho 'nuf, this was a good idea, because there seems to be a problem :-(

What I find is that the openssl tests both pass fine on FC3, but the rpl_openssl
one fails (it just hangs forever) on FC4.  All seven supported arches behave the
same, so it's not platform-specific; I'm inclined to think it's got something to
do with the newer version of OpenSSL in FC4.

I'm currently pursuing the theory that the root cause is insufficient locking
inside mysqld, as described here:
http://bugs.mysql.com/bug.php?id=9270

Comment 3 Tom Lane 2005-07-13 03:21:11 UTC
Turns out that this isn't an SSL issue at all, but sloppy design of the regression test:
http://bugs.mysql.com/bug.php?id=10860
Still it's good to have the test passing.  I have a workaround in place in mysql-4.1.12-1 and up.
Thanks for the report!


Note You need to log in before you can comment on or make changes to this bug.