Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155847 - SUPPORTED in /etc/sysconfig/i18n is not setup correctly
Summary: SUPPORTED in /etc/sysconfig/i18n is not setup correctly
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker 155836
TreeView+ depends on / blocked
 
Reported: 2005-04-24 16:47 UTC by Ronny Buchmann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-27 21:51:22 UTC


Attachments (Terms of Use)
generated anaconda-ks.cfg (deleted)
2005-04-24 16:47 UTC, Ronny Buchmann
no flags Details
anaconda install log (deleted)
2005-04-24 16:48 UTC, Ronny Buchmann
no flags Details

Description Ronny Buchmann 2005-04-24 16:47:47 UTC
When selecting additional language support groups in the package selection, the
corresponding language codes should be added to SUPPORTED in /etc/sysconfig/i18n.

Version-Release number of selected component (if applicable):
10.2.0.52

How reproducible:
always

Steps to Reproduce:
1. graphicall installation selecting some language groups

Comment 1 Ronny Buchmann 2005-04-24 16:47:47 UTC
Created attachment 113611 [details]
generated anaconda-ks.cfg

Comment 2 Ronny Buchmann 2005-04-24 16:48:49 UTC
Created attachment 113612 [details]
anaconda install log

Comment 3 Ronny Buchmann 2005-04-24 16:54:29 UTC
correction to initial report:

In graphical installation SUPPORTED is set to en_US... independent of the
installation language.

In text mode you don't have fine grained control over the installed languages,
so this is not applicable. (SUPPORTED is correctly set up with the only
installed language)

Comment 4 Jeremy Katz 2005-04-24 18:57:13 UTC
It might even make sense to go to not writing out SUPPORTED at all... it was
mostly used as a hint for setting %_install_langs for rpm installs, but since we
don't want to do that anymore, it may be superfluous.

Comment 5 Ronny Buchmann 2005-04-24 20:30:42 UTC
SUPPORTED is used by system-config-language to show available languages. This
may not be the optimal solution, but I wouldn't change it for FC4 - it's simply
too late.

Comment 6 Chris Lumens 2005-04-25 14:08:07 UTC
You're doing things backwards - add all languages you want to be supported after
the "langsupport" keyword in your kickstart file and omit the "whatever-support"
package listings.  The presence of the language after langsupport will
automatically select the appropriate support package and set up SUPPORTED properly.

Comment 7 Ronny Buchmann 2005-04-25 17:13:35 UTC
I'm talking about interactive installs, not kickstart.
The kickstart file in #2 is the one created by anaconda. I attached it only to
show what I have selected.

Comment 8 Jeremy Katz 2005-04-27 19:37:28 UTC
Either way we're making a change to something later than I'd like.  I'll do some
closer looking at this later today.

Comment 9 Ronny Buchmann 2005-04-27 21:31:29 UTC
Maybe it would make sense to store (the full) lang-table in /etc/sysconfig and
use that in s-c-language. (In the case anaconda isn't doing something strange
with languages anymore)
Alternatively, change yum, up2date, s-c-packages to generate something from the
actually installed groups.

Comment 10 Jeremy Katz 2005-04-27 21:51:22 UTC
system-config-language acts fairly sane on my laptop with no SUPPORTED line set.
 So anaconda will now only write out SUPPORTED if you're doing odd things in
kickstart.  And that will probably go away eventually as well.


Note You need to log in before you can comment on or make changes to this bug.