Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155835 - openoffice will not start
Summary: openoffice will not start
Keywords:
Status: CLOSED DUPLICATE of bug 155810
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-24 13:40 UTC by Sylvain Rouillard
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 07:55:08 UTC


Attachments (Terms of Use)

Description Sylvain Rouillard 2005-04-24 13:40:44 UTC
Description of problem:
None of the openoffice applications will start.

Version-Release number of selected component (if applicable):
openoffice.org-1:1.9.93-1


How reproducible:
Always

Steps to Reproduce:
1. Try and start an openoffice application (icon menu or console call)
  
Actual results:
Nothing starts. Here is what can be seen when trying to launch them from the
command line:
[sal@localhost ~]$ oocalc
/usr/lib/openoffice.org1.9.93/program/soffice: line 241: 20092 Erreur de
segmentation  "$sd_prog/$sd_binary" "$@"
[sal@localhost ~]$ oowriter
/usr/lib/openoffice.org1.9.93/program/soffice: line 241: 20146 Erreur de
segmentation  "$sd_prog/$sd_binary" "$@"
[sal@localhost ~]$ oodraw
/usr/lib/openoffice.org1.9.93/program/soffice: line 241: 20161 Erreur de
segmentation  "$sd_prog/$sd_binary" "$@"
[sal@localhost ~]$ ooimpress
/usr/lib/openoffice.org1.9.93/program/soffice: line 241: 20172 Erreur de
segmentation  "$sd_prog/$sd_binary" "$@"
[sal@localhost ~]$ ooffice
/usr/lib/openoffice.org1.9.93/program/soffice: line 241: 20183 Erreur de
segmentation  "$sd_prog/$sd_binary" "$@"
[sal@localhost ~]$ oobase
/usr/lib/openoffice.org1.9.93/program/soffice: line 241: 20195 Erreur de
segmentation  "$sd_prog/$sd_binary" "$@"
[sal@localhost ~]$ oomath
/usr/lib/openoffice.org1.9.93/program/soffice: line 241: 20208 Erreur de
segmentation  "$sd_prog/$sd_binary" "$@"
[sal@localhost ~]$ ooviewdoc
/usr/lib/openoffice.org1.9.93/program/soffice: line 241: 20221 Erreur de
segmentation  "$sd_prog/$sd_binary" "$@"

For the translation, "Erreur de segmentation" means segfault.

Expected results:
The appropriate OOo application should start.

Additional info:
OOo used to work pretty well, though I cannot relly tell when it stopped
working. Possibly after last yum update (23/04) or sometime last week.

Comment 1 Jason Powers 2005-04-24 18:42:21 UTC
I get the same error in the english version. I ran yum -y update on saturday
April 23rd and it completed, so I'm at fc4t2, kernel 2.6.11-1.1261_FC4_x86_64,
everything install. I do these complete installs over and over and file bug
reports, but I'm getting the exact same behavior Sylvain is, so I'll just chime
in that it's not an isolated incident.

/usr/lib/openoffice.org1.9.93/program/soffice: line 230:  3689 Segmentation
fault      "${sd_prog}"/pagein -L"${sd_prog}" ${sd_pagein_args}
/usr/lib/openoffice.org1.9.93/program/soffice: line 241:  3690 Segmentation
fault      "$sd_prog/$sd_binary" "$@"

Jason

Comment 2 Jason Powers 2005-04-24 19:14:12 UTC
OK I went back to kernel 2.6.11-1.1251_FC4_x86_64 and the new openoffice works
fine. I don't know how to debug a kernel so that's all the info I have.

Comment 3 Caolan McNamara 2005-04-25 07:55:08 UTC

*** This bug has been marked as a duplicate of 155810 ***


Note You need to log in before you can comment on or make changes to this bug.