Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155818 - Bash auto-completion doesn't work under konsole
Summary: Bash auto-completion doesn't work under konsole
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kdebase
Version: 4.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
: 154930 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-24 00:30 UTC by Patrice Guay
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 15:21:05 UTC


Attachments (Terms of Use)

Description Patrice Guay 2005-04-24 00:30:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Red Hat/1.0.3-1.4.1.TL1 Firefox/1.0.3

Description of problem:
Under konsole, hitting TAB is not enough to obtain auto-completion. You need to press another key before completion is displayed.

Version-Release number of selected component (if applicable):
kdebase-3.3.1-5.5

How reproducible:
Always

Steps to Reproduce:
1. Open konsole
2. Type: more /etc/X11/xorg.co
3. Press Enter. You get an error message because file doesn't exist
4. Type again: more /etc/X11/xorg.co
5. Press Tab to get auto-completion

  

Actual Results:  Nothing is displayed. If you press another key, say "x", you have:
more /etc/X11/xorg.confx

Expected Results:  When I press Tab, I should get:
more /etc/X11/xorg.conf

I shouldn't have to type another key before seeing the auto-completed command line.

Additional info:

This problem is not present under other graphical console programs like xterm and gnome-console.

Comment 1 Tim Waugh 2005-04-25 08:51:52 UTC
*** Bug 154930 has been marked as a duplicate of this bug. ***

Comment 2 Ngo Than 2005-04-25 15:21:05 UTC
sorry, i have tried to reproduce this problem on fresh rhel4 installation. It
works fine for me. I used the auto-completion everyday with konsole and have not
seen this problem. It's surely a bash config problem here.


Note You need to log in before you can comment on or make changes to this bug.