Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155812 - rpm conflict with clamav
Summary: rpm conflict with clamav
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: logwatch
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jiri Ryska
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-23 19:59 UTC by Zenon Panoussis
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 14:33:47 UTC


Attachments (Terms of Use)

Description Zenon Panoussis 2005-04-23 19:59:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1

Description of problem:
Attempting to update 5.2.2-1 with 5.2.2-1.FC3 using up2date fails due to a conflict about /etc/log.d/conf/services/clamav.conf, which is owned by the clamav package. 

clamav is not part of the official FC3 distribution, so FC3's logwatch should not contain/claim its files. 

As an aside, yum had no problems with this; it just went right on and made a mess:

Downloading Packages:
(1/1): logwatch-5.2.2-1.F 100% |=========================| 140 kB    00:01
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating: logwatch 100 % done 1/2
Completing update for logwatch  - 2/2

Updated: logwatch.noarch 0:5.2.2-1.FC3
Complete!

# rpm -qf /etc/log.d/conf/services/clamav.conf
clamav-0.80rc4-1
logwatch-5.2.2-1.FC3

I guess taht's a different bug...


Version-Release number of selected component (if applicable):
5.2.2-1.FC3

How reproducible:
Didn't try

Steps to Reproduce:
1. Install the clamav rpm from clamav.net
2. Use up2date to update logwatch


  

Additional info:

Comment 1 Jiri Ryska 2005-04-26 14:33:47 UTC
This is not a bug of logwatch (especially against package not provided by
RedHat), but bug of clamav. Btw, the latest clamav (clamav-0.83-1) solves this
problem.


Note You need to log in before you can comment on or make changes to this bug.