Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155785 - Wrong architecture directory in the rpm
Summary: Wrong architecture directory in the rpm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pvm
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Brian Brock
URL:
Whiteboard:
: 163801 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-23 00:14 UTC by Leo Lopes
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 3.4.5-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-19 10:15:25 UTC


Attachments (Terms of Use)

Description Leo Lopes 2005-04-23 00:14:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1

Description of problem:
When I upgraded form FC2 to FC3, apparently the PVM_ARCH changed from LINUXI386 to LINUX. By the way in `man pvm_intro` the architecture listed is LINUX. However, in the rpm the architecture-specific subdir created is LINUXI386.

Version-Release number of selected component (if applicable):
pvm-3.4.5-2_FC3

How reproducible:
Always

Steps to Reproduce:
1. Install the RPM
2. In a Makefile.aimk, create a target like:
showArch:
    @echo The PVM architecture is $PVM_ARCH
3. Compare that to rpm -qlf pvm-3.4.5-2_FC3.rpm | grep LINUX

  

Actual Results:  trying to link against the PVM libraries fail if $PVM_ARCH is used to create a Makefile that can be used in other architectures as well.

Expected Results:  program should just link.

Additional info:

Workaround: Create links from LINUX-> LINUXI386 in each relevant subdirectory of /usr/share/pvm3:

(as root)
cd /usr/share/pvm3
for dir in `ls -d */LINUXI386 | cut -f1 -d"/"`; do ln -s LINUXI386 $dir/LINUX; done

Comment 1 Jason Vas Dias 2005-06-01 21:21:43 UTC
This bug is now fixed with pvm-3.4.5-5_FC3 .
The architecture specific subdirectory names now agree with 
pvmgetarch output. 
pvm-3.4.5-5_FC3 will be in fc3-updates shortly. Meanwhile, you can
download it from:
  http://people.redhat.com/~jvdias/pvm/FC3
Please try it out and let me know of any issues - thank you.


Comment 2 Jason Vas Dias 2005-07-21 15:19:14 UTC
*** Bug 163801 has been marked as a duplicate of this bug. ***

Comment 3 Walter Justen 2005-08-19 10:15:25 UTC
update package is published


Note You need to log in before you can comment on or make changes to this bug.