Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155721 - A system with a valid systemid should not require the username to validate the login process
Summary: A system with a valid systemid should not require the username to validate th...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend
Version: rhn400
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Wregglesworth
QA Contact: Max Spevack
URL:
Whiteboard:
: 155720 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-22 15:13 UTC by John Wregglesworth
Modified: 2007-04-18 17:24 UTC (History)
2 users (show)

Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-01 03:04:19 UTC


Attachments (Terms of Use)

Description John Wregglesworth 2005-04-22 15:13:38 UTC
Description of problem: When a system, with a valid systemid checkin to the
satellite, we should not require the username (which we log in the systemid file
on registration) to validate the login process for the client system. This
causes a problem when a user is removed; the client systems can't log in anymore
because the username contained in the systemid isn't valid anymore.

Comment 1 John Wregglesworth 2005-04-22 15:32:12 UTC
See BZ#155453 for customer report.

Comment 2 Debbie McGrath 2005-04-27 21:17:29 UTC
*** Bug 155720 has been marked as a duplicate of this bug. ***

Comment 3 John Wregglesworth 2005-05-09 20:44:29 UTC
Test Plan:

o Log in as the Org Admin.

o Create a new user.

o Using the new user's username and password, register a client machine to your
account.

o As the Org Admin, delete the new user.

o Go to the Packages tab for the system you registered with the deleted user's
info and schedule a package install.

o On the client machine, run rhn_check. The package install should go through,
which can be verified by checking the System History in the Events tab for the
system.

o Schedule a package upgrade on the machine through the web ui.

o On the client machine, run rhn_check. The upgrade should go through. This can
also be verified by checking the System History in the Events tab.

o Use the same basic process for testing package verification and package
removal. Namely, schedule the action, run rhn_check on the target system, and
make sure the action ran as expected by checking the Events tab.

o Use up2date to install packages. This shouldn't have any problems.

There shouldn't be any systemid related problems when doing any of the above.  


Comment 4 Beth Nackashi 2005-08-04 16:07:59 UTC
deleting a user doesn't work -- see
https://bugzilla.redhat.com/bugzilla/post_bug.cgi

Comment 5 Beth Nackashi 2005-08-05 01:31:27 UTC
sheesh -- ignore Comment #4.  This is what it should have said:

deleting a user doesn't work -- see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=165131

REQUIRES FIX TO 165131 BEFORE RETESTING.

Comment 6 Max Spevack 2005-08-10 01:30:39 UTC
up2date works
rhn_check install, verify works

PROD_READY


Note You need to log in before you can comment on or make changes to this bug.