Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155704 - RFE: Roll back feature for an errata
Summary: RFE: Roll back feature for an errata
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe deBlaquiere
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-22 13:12 UTC by Asgeir Nilsen
Modified: 2007-10-24 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 18:28:06 UTC


Attachments (Terms of Use)

Description Asgeir Nilsen 2005-04-22 13:12:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
Some times, applying an errata might break things, and you would like to roll back a change.  There seems to be no simple, straight-forward way to do this on RHN today.

You have a very good WUI for showing the history of all changes, and, provided up2date repackages, rolling back the change should be straight-forward.

Version-Release number of selected component (if applicable):
rpm-4.2.2-0.14 up2date-4.2.16-1

How reproducible:
Always

Steps to Reproduce:
1. Apply errata
2. Discover problem
3. Cannot roll back automatically!
  

Additional info:

Comment 1 Joe deBlaquiere 2005-04-25 18:28:06 UTC
RHN Provisioning Module ( http://www.redhat.com/software/rhn/provisioning/ )
provides this function. With Provisioning entitlements, all systems maintain a
complete history of snapshots and can be rolled back (as long as they boot and
connect to the network) to a previous state. 


Note You need to log in before you can comment on or make changes to this bug.