Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155701 - libgcc %post script failure for Raw Hide kickstart
Summary: libgcc %post script failure for Raw Hide kickstart
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-22 12:45 UTC by Joe Orton
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 4.0.0-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 20:24:26 UTC


Attachments (Terms of Use)

Description Joe Orton 2005-04-22 12:45:58 UTC
Installing libgcc-4.0.0-0.42.i386.
error: %post(libgcc-4.0.0-0.42.i386) scriptlet failed, exit status 0

though I'm not sure what kind of "failure" exit status 0 is exactly...

Comment 1 Jakub Jelinek 2005-04-24 11:25:40 UTC
Is this on ia64 with ia32el not installed or something?

Comment 2 Joe Orton 2005-04-24 13:07:29 UTC
No, perfectly normal x86 installation.

Comment 3 Jakub Jelinek 2005-04-26 11:05:46 UTC
Sounds like rpm bug anyway.  There were no changes to the libgcc's %post
since mid February and all that binary does is access /sbin/ldconfig and
execl /sbin/ldconfig if it exists.
If you run /usr/sbin/libgcc_post_upgrade; echo $?
by hand, does it print 0?


Comment 4 Joe Orton 2005-04-28 17:13:54 UTC
[root@trash ~]# /usr/sbin/libgcc_post_upgrade
[root@trash ~]# echo $?
0
[root@trash ~]# rpm -q libgcc
libgcc-4.0.0-1

still saw this with on a kickstart of this morning's Raw Hide snapshot

rpm-4.4.1-11
anaconda-10.2.0.55-1


Comment 5 Jeremy Katz 2005-05-06 17:07:44 UTC
Back to gcc...  mv /sbin/ldconfig /sbin/ldconfig.old ; /usr/sbin/libgcc_post_upgrade

Watch it segfault :-)

Comment 6 Jakub Jelinek 2005-05-16 20:24:26 UTC
Should be fixed in libgcc-4.0.0-5.


Note You need to log in before you can comment on or make changes to this bug.