Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155693 - [OO][gcj]Provider for javax.xml.parsers.SAXParserFactory cannot be found
Summary: [OO][gcj]Provider for javax.xml.parsers.SAXParserFactory cannot be found
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xml-commons
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-22 12:10 UTC by Caolan McNamara
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 09:51:50 UTC


Attachments (Terms of Use)
Eclipse log with failure. (deleted)
2005-04-23 23:44 UTC, Andrew Overholt
no flags Details

Description Caolan McNamara 2005-04-22 12:10:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050330

Description of problem:
> rpm -q xml-commons-apis
xml-commons-apis-1.0-0.b2.6jpp_5fc
> gij mytest
> rpm --upgrade xml-commons-1.0-0.b2.6jpp_6fc.noarch.rpm
> gij mytest
Exception in thread "main" javax.xml.parsers.FactoryConfigurationError: Provider for javax.xml.parsers.SAXParserFactory cannot be found
   at javax.xml.parsers.SAXParserFactory.newInstance() (Unknown Source)
   at mytest.main(java.lang.String[]) (Unknown Source)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)

Version-Release number of selected component (if applicable):
xml-commons 1.0-0.b2.6jpp_6fc

How reproducible:
Always

Steps to Reproduce:
> cat mytest.java
import javax.xml.parsers.*;

public class mytest
{
    static public void main(String[] args)
    {
        SAXParserFactory spf = SAXParserFactory.newInstance();
    }
}


Expected Results:  regression ? between 5fc and 6fc

Additional info:

Blocks building OOo2

Comment 1 Caolan McNamara 2005-04-22 12:27:46 UTC
FWIW: manually removing /usr/share/java/gcj-endorsed-xml-commons-apis-1.0.jar
gets rid of the error

Comment 2 Gary Benson 2005-04-22 12:46:44 UTC
Yeah, I see this on my box too...

Comment 3 Gary Benson 2005-04-22 12:52:11 UTC
Ah, it's because you have not specified a parser.  Previously you were using
libgcj's implementation of javax.xml.parsers.SAXParserFactory which provided a
default if none was set, whereas now you're using the xml-commons one which has
no default.

Comment 4 Gary Benson 2005-04-22 13:22:33 UTC
Fixed in xml-commons-1.0-0.b2_6jpp_7fc

Comment 5 Andrew Overholt 2005-04-23 23:43:54 UTC
I'm getting similar behaviour now trying to run Eclipse, but with:

Caused by: javax.xml.parsers.FactoryConfigurationError: Provider for
javax.xml.parsers.DocumentBuilderFactory cannot be found

I'll attach my Eclipse log.

Comment 6 Andrew Overholt 2005-04-23 23:44:40 UTC
Created attachment 113588 [details]
Eclipse log with failure.

Comment 7 Andrew Overholt 2005-04-23 23:46:20 UTC
I forgot the versions:

xml-commons-1.0-0.b2.6jpp_7fc
xml-commons-apis-1.0-0.b2.6jpp_7fc
libgcj-4.0.0-0.42
eclipse-platform-3.1.0_fc-0.M6.10

Comment 8 Gary Benson 2005-04-25 09:51:50 UTC
Fixed in xml-commons-1.0-0.b2_6jpp_8fc

Comment 9 Phil Muldoon 2005-04-25 22:53:34 UTC
I installed the xml-commons rpms from beehive, and it still fails:

rpm -q xml-commons
xml-commons-1.0-0.b2.6jpp_9fc

rpm -q xml-commons-apis
xml-commons-apis-1.0-0.b2.6jpp_9fc

I'll leave it closed until it propogates to rawhide tommorrow, to be sure that I
have not missed any other dependencies (I'll have yum do all the updating).


Comment 10 Gary Benson 2005-04-26 15:43:20 UTC
I've backed out the changes that caused these problems for
xml-commons-1.0-0.b2.6jpp_10fc.


Note You need to log in before you can comment on or make changes to this bug.