Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155656 - INFO Test hangs
Summary: INFO Test hangs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: rhr2
Version: 2
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Rob Landry
QA Contact: Rob Landry
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-22 10:18 UTC by Gajalakshmi
Modified: 2007-04-18 17:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-08 20:08:20 UTC


Attachments (Terms of Use)

Description Gajalakshmi 2005-04-22 10:18:35 UTC
Description of problem:
We are doing one redhat-certification on  an  AMD based Server board.
While we run INFO test after completing all tests we are getting
message like below on the screen.

Code f3 90 7e f5 e9 28 d1 ff ff 80 b8 a0 00 00 00 00 f3 90 7e f5 

Console shuts up....

After this we could not able to proceed further.

Version-Release number of selected component (if applicable):  -


How reproducible: Not known


Steps to Reproduce:
1.
2.
3.
  
Actual results:INFO test hangs
Expected results:INFO test should pass


Additional info: When we run sysreport the system hangs. Unable to generate 
report. Main cause for INFO test failure.

Comment 1 Richard Li 2005-04-22 12:41:32 UTC
Is this reproducible? (You say not known -- did you try more than once? after
rebooting?)

If you run sysreport manually and the system hangs, this is not a bug in RHR.

On what line (or phase) of sysreport do you encounter a problem?

We need to know what OS version, what the hardware is you're running, etc.
Please provide as much information as possible.

Comment 2 Rob Landry 2005-04-22 14:47:03 UTC
I would suggest adding...

set -xv

...to the top of /usr/sbin/sysreport.  This will cause sysreport to display each
line before execution, thusly you should be able to see what the last command
run was.  Then after rebooting attempt the same command on the command line and
see if it reproduces the problem.

Comment 3 Gajalakshmi 2005-04-23 09:08:57 UTC
Found it is hanging while running this command:
/bin/cp --parents -R /proc/scsi /tmp/sysreport.3007
so I commented statement: #cattifile "/proc/scsi" and it is successful.why it 
is hanging at this point and how can I resolve this.

Comment 4 Rob Landry 2005-04-25 14:06:04 UTC
From other email it appears this is the log where this dies...

lstat("/proc/scsi/aic79xx", {st_mode=S_IFDIR|0555, st_size=0, ...}) = 0
lstat("/tmp/sysreport.3007/proc/scsi/aic79xx", {st_mode=S_IFDIR|0755,
st_size=4096, ...}) = 0
open("/proc/scsi/aic79xx", O_RDONLY|O_NONBLOCK|O_DIRECTORY) = 3
fstat(3, {st_mode=S_IFDIR|0555, st_size=0, ...}) = 0
fcntl(3, F_SETFD, FD_CLOEXEC)           = 0
getdents64(3, /* 3 entries */, 1024)    = 72
getdents64(3, /* 0 entries */, 1024)    = 0
close(3)                                = 0
lstat("/proc/scsi/aic79xx/0", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
lstat("/tmp/sysreport.3007/proc/scsi/aic79xx/0", {st_mode=S_IFREG|0644,
st_size=0, ...}) = 0
open("/proc/scsi/aic79xx/0", O_RDONLY)  = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
open("/tmp/sysreport.3007/proc/scsi/aic79xx/0", O_WRONLY|O_TRUNC) = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
fstat(3, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
read(3, 

...which seems to indicate that there's a problem reading from the Adaptec
driver info.  Assuming that is correct, the first thing I'd suggest is to see
how the updated kernels react as this does not appear to be a test suite issue,
the two newer ones to try would be the RHEL4 errata kernel and the U1 beta
kernel, both are available in RHN.

Comment 5 Gajalakshmi 2005-04-26 14:06:31 UTC
Give me the link from where I can get this RHEL4 Errata kernel and U1 beta 
kernel.

Comment 6 Gajalakshmi 2005-05-02 10:16:00 UTC
pls. provide URL for RHEL4 Errata Kernel and U1 beta kernel.


Comment 7 Gajalakshmi 2005-05-20 05:19:13 UTC
pls. help to get the req. kernel. give url

Comment 8 Gajalakshmi 2005-08-29 06:13:26 UTC
This Bug can be closed. The problem solved with New BIOS from Motherboard 
vendor.


Note You need to log in before you can comment on or make changes to this bug.