Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155630 - Cannot update hardware profile; unable to register; Reading DMI info failed
Summary: Cannot update hardware profile; unable to register; Reading DMI info failed
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-22 00:03 UTC by Pamela Fong
Modified: 2007-11-30 22:07 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-26 21:36:06 UTC


Attachments (Terms of Use)
Output of running the utility, dmidecode (deleted)
2005-04-22 08:03 UTC, Pamela Fong
no flags Details
output of lspci -v (deleted)
2005-08-29 20:22 UTC, James Jaeger
no flags Details
output from python hardware command (deleted)
2005-08-29 20:24 UTC, James Jaeger
no flags Details
dmidecode from SunFire V65 (deleted)
2006-07-25 14:42 UTC, Bob Gautier
no flags Details
up2date_client.hardware.Hardware() output for SunFire V65 (deleted)
2006-07-25 14:45 UTC, Bob Gautier
no flags Details
lspci -v from SunFire V65 (deleted)
2006-07-25 14:46 UTC, Bob Gautier
no flags Details

Description Pamela Fong 2005-04-22 00:03:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050319

Description of problem:
When I run, "up2date --hardware" or try to activate our campus sitewide licensed RHN subscription, I get the error, "Reading DMI info failed".  Running "dmidecode" doesn't give any error.  Result is I cannot get updates.

Version-Release number of selected component (if applicable):
up2date-4.4.5-1

How reproducible:
Always

Steps to Reproduce:
1.  up2date --hardware
2.  /usr/sbin/rhnreg_ks --force --activationkey=00000000-real-key-code-omitted-000000000
3.
  

Actual Results:  Reading DMI info failed

Expected Results:  System registers successfully

Additional info:

I installed RedHat Enterprise 4 Advanced Server on a virtual machine running in Microsoft Virtual PC 2004 SR1 installed on a Dell Inspiron 8500 laptop.  I get an error when I try to activate our campus access to Red Hat Network updates using,

[root@vpc ~]# /usr/sbin/rhnreg_ks
--activationkey=00000000-real-key-code-omitted-000000000
This system is already registered. Use --force to override
[root@vpc ~]# /usr/sbin/rhnreg_ks --force
--activationkey=00000000-real-key-code-omitted-000000000
Reading DMI info failed

Researching Bugzilla reports (e.g. 145855) for other versions and hardware led me to run these diagnostics,

[root@vpc ~]# up2date --hardware
Updating hardware profile...
Reading DMI info failed

[root@vpc ~]# dmidecode > dmidecode.txt

  [contents of dmidecode.txt submitted as attachment]

---Pam

Comment 1 Pamela Fong 2005-04-22 08:03:41 UTC
Created attachment 113516 [details]
Output of running the utility, dmidecode

Comment 2 Pamela Fong 2005-04-23 01:42:38 UTC
I didn't look carefully.  There are errors listed in the dmidecode output.  The 
version package providing dmidecode is,

  kernel-utils-2.4-13.1.48

---Pam



Comment 3 Mihai Ibanescu 2005-07-29 15:28:26 UTC
Can I please get the output of:
/sbin/lspci -v

Comment 4 Mihai Ibanescu 2005-08-03 12:27:56 UTC
Also, can you please run:

PYTHONPATH=/usr/share/rhn python -c "from up2date_client import hardware; print 
hardware.Hardware()" > /tmp/hardware-info.txt

and attach /tmp/hardware-info.txt

Comment 5 James Jaeger 2005-08-26 19:51:33 UTC
We are having the same problem with out Bitstream 360. Has there been a
resolution to this problem?

Comment 6 Mihai Ibanescu 2005-08-26 20:34:27 UTC
James, can you please attach the contents required in comment #3 and comment #4?
You can also email them directly to me.

Comment 7 James Jaeger 2005-08-29 20:22:41 UTC
Created attachment 118226 [details]
output of lspci -v

Comment 8 James Jaeger 2005-08-29 20:24:47 UTC
Created attachment 118227 [details]
output from python hardware command

Comment 9 Sabrina 2005-10-07 14:24:06 UTC
We are having the same problem with Redhat AS3.0. We can't register using 
command rhnreg_ks. We get the error, "Reading DMI info failed".
Also command
up2date --hardware
and    
PYTHONPATH=/usr/share/rhn python -c "from up2date_client import hardware; print 
hardware.Hardware()"
generate "Reading DMI info failed".
Dmidecode output is good!
We have following version of rpms 
kernel-utils-2.4-8.37.12
kernel-2.4.21-37.EL
kernel-source-2.4.21-37.EL
up2date-4.4.44-3
up2date-gnome-4.4.44-3
Thanks 
Sabrina



 

Comment 12 Fanny Augustin 2006-04-11 00:45:49 UTC
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release

Comment 13 Fanny Augustin 2006-04-13 20:01:09 UTC
Moving bugs to the CanFix List

Comment 14 Fanny Augustin 2006-05-08 19:44:35 UTC
This bug did not make the code freeze and it will not be fiixed during this
release cycle.  Re-aligning bug to the next release

Comment 15 Fanny Augustin 2006-05-08 20:12:51 UTC
This bug did not make the code freeze.  It will not be fixed in this releasee 
Reea ligning to the next one.

Comment 16 Bob Gautier 2006-07-25 14:40:16 UTC
I am having a similar problem on a SunFire V65 running RHEL4u3

up2date version 4.4.67-4
kernel-utils 2.4-13.1.80

dmidecode works, but up2date gives me 'Reading DMI info failed'.  I'll attach 
the diagnostic files you asked for above.

Is there an errata update in the pipeline?

Comment 17 Bob Gautier 2006-07-25 14:42:59 UTC
Created attachment 132990 [details]
dmidecode from SunFire V65

Comment 18 Bob Gautier 2006-07-25 14:45:19 UTC
Created attachment 132991 [details]
up2date_client.hardware.Hardware() output for SunFire V65

Comment 19 Bob Gautier 2006-07-25 14:46:31 UTC
Created attachment 132992 [details]
lspci -v from SunFire V65

Comment 20 James Bowes 2006-07-26 21:36:06 UTC

*** This bug has been marked as a duplicate of 149177 ***

Comment 21 James Bowes 2006-07-26 21:38:48 UTC

*** This bug has been marked as a duplicate of 149177 ***

Comment 22 James Bowes 2006-11-02 19:36:39 UTC

*** This bug has been marked as a duplicate of 196493 ***


Note You need to log in before you can comment on or make changes to this bug.