Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155616 - system-config-samba doesn't gracefully handle syntax errors in smb.conf
Summary: system-config-samba doesn't gracefully handle syntax errors in smb.conf
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-samba
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-21 20:56 UTC by Ian Richardson
Modified: 2008-08-14 15:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-14 15:22:34 UTC


Attachments (Terms of Use)
my old smb.conf (deleted)
2005-04-21 21:02 UTC, Ian Richardson
no flags Details
The fixed version of smb.conf (deleted)
2005-04-21 21:03 UTC, Ian Richardson
no flags Details

Description Ian Richardson 2005-04-21 20:56:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
When you go to:
system settings > server settings > click on samba

It asks you for the root password and then just hangs afterwards.



Version-Release number of selected component (if applicable):
system-config-samba-1.2.21-1 and python-2.3.4-11

How reproducible:
Always

Steps to Reproduce:
1.system settings
2.server settings
3.click on samba
4.enter root password
  

Actual Results:  nothing comes up

Expected Results:  samba configuration tool to load up.

Additional info:

when system-config-samba is run from a terminal; it errors with:
" File "/usr/share/system-config-samba/sambaToken.py", line 36, in __init__
raise AttributeError, value
AttributeError: ('192.168.0.3', '') "

Problem is solved by removing my smb.conf and then making another.

Comment 1 Ian Richardson 2005-04-21 21:02:11 UTC
Created attachment 113489 [details]
my old smb.conf

This is the config file that the problem happens under

Comment 2 Ian Richardson 2005-04-21 21:03:34 UTC
Created attachment 113490 [details]
The fixed version of smb.conf

Once i had changed it to this smb.conf the problem was resolved

Comment 3 Nils Philippsen 2005-06-14 15:18:32 UTC
Your original smb.conf contains IP addresses on their own lines, these must be
on one line with the "host allow" parameter. I plan to change s-c-samba so that
it gives a suitable warning in that case.

Comment 4 Nils Philippsen 2008-08-14 15:22:34 UTC
Current system-config-samba-1.2.63-1.fc9.noarch gives such a warning and doesn't hang.


Note You need to log in before you can comment on or make changes to this bug.