Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155607 - prelink segfaults when reading corrupted ELF files
Summary: prelink segfaults when reading corrupted ELF files
Keywords:
Status: CLOSED DUPLICATE of bug 155605
Alias: None
Product: Fedora
Classification: Fedora
Component: prelink
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-21 19:03 UTC by Michal Marek
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-21 19:21:55 UTC


Attachments (Terms of Use)

Description Michal Marek 2005-04-21 19:03:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Fedora/1.7.6-1.3.2

Description of problem:
After building a custom Python RPM, the daily prelink run segfaulted when prelinking /usr/lib/debug/usr/bin/python.debug. It's nothing critical, since the python.debug file is probably broken anyway, but prelink should print a warning message and continue instead. I wrote a quick patch which just silently ignores it, will attach that.

Version-Release number of selected component (if applicable):
prelink-0.3.3, prelink-0.3.4 from devel too

How reproducible:
Always

Steps to Reproduce:
1. Create a corrupted ELF file (will attach one)
2. run 'prelink /path/to/file' or 'prelink -a'

  

Actual Results:  Segmentation fault (core dumped)


Expected Results:  "File %s is corrupted, not prelinking" or something like that.

Additional info:

Only special configuration is that debug file I'll attach, everything else is a normal FC3 install.

Comment 1 Michal Marek 2005-04-21 19:21:55 UTC
Must have pressed that button twice...

*** This bug has been marked as a duplicate of 155605 ***


Note You need to log in before you can comment on or make changes to this bug.