Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155594 - kernel panic due to not finding lvm volumes
Summary: kernel panic due to not finding lvm volumes
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-21 17:48 UTC by Thomas J. Baker
Modified: 2015-01-04 22:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-16 18:39:42 UTC


Attachments (Terms of Use)

Description Thomas J. Baker 2005-04-21 17:48:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
After updating yesterday to the 1251 kernel, my Dell Inspiron 600m with just a standard ide disk crashed on boot after not finding/activating any lvm partitions in the single lvm on this system. Because the meat of the error scrolled off the screen, I rebooted and added vga=792 to the kernel cmdline so I could see what was happening. Sad thing is, it booted fine. This afternoon, I updated to the 1253 kernel and am experiencing the same thing. Before the kernel panic lines, it says something to the effect of "/bin/lvm exitted with an error". It sees the lvm because it prints something about vgc0 but it can't see the partitions in it. By adding vga=792, the error doesn't occur. Maybe it's a timing thing and the higher resolution slows something down just enough?

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1251_FC4, kernel-2.6.11-1.1253_FC4

How reproducible:
Always

Steps to Reproduce:
1.boot the 1251 or 1253 kernels on his 600m laptop
2.
3.
  

Actual Results:  kernel panic after not being able to activate any partitions in lvm vgc0

Expected Results:  partitions are seen and boot occurs normally.

Additional info:

I'll reboot one more time to give the exact lvm error.

Comment 1 Thomas J. Baker 2005-04-21 17:57:13 UTC
It actually is not finding any volumes. I get the error "No Volume Groups Found"
and then ERROR: /bin/lvm exited abnormally! The vgc0 must be being picked up
from the kernel cmdline.

These kernels works fine on another test system I have but that one is SCSI based.

Comment 2 Thomas J. Baker 2005-04-22 01:33:10 UTC
I just had it happen even with the vga=792 so that's not a perfect fix. Since I
did have it enabled, I was able to see pretty far back in the boot sequence.
There were two instances of "/bin/udevstart exited abnormally!" so that might
have had something to do with it. 

When this happens, the three finger salute doesn't work and I have to power
cycle the machine so it's not due to hardware being left in some funky state. It
happens from a cold boot. If it matters, I also have had consistent problems
with FC4Tx kernels and resume not working reliably and also with cpuspeed not
working all the time. I'll file a separate bug about cpuspeed.

Comment 3 Thomas J. Baker 2005-04-22 01:43:57 UTC
FWIW, the cpuspeed problem seems to be bug #137995.

Comment 4 Thomas J. Baker 2005-04-24 22:39:51 UTC
I'm still seeing this with the 1261 kernel. It's now happening on two laptops, a
Dell 600m and a Dell 7500. It sometimes takes three or four boots before the lvm
partitions are seen correctly.

Comment 5 Thomas J. Baker 2005-05-16 18:39:42 UTC
This seems to be fixed in later kernels.


Note You need to log in before you can comment on or make changes to this bug.