Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155590 - realplayer installation creates directory with bad permissions when umask is 0077
Summary: realplayer installation creates directory with bad permissions when umask is ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: realplayer
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-21 17:19 UTC by Jeremy Dreese
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:04:18 UTC


Attachments (Terms of Use)

Description Jeremy Dreese 2005-04-21 17:19:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Red Hat/1.0.3-1.4.1 Firefox/1.0.3

Description of problem:
If you have your umask set to 0077 and try to install the realplayer RPM from the RHN, it creates a directory, /usr/lib/helix, that has permissions 0700.  With these permissions, normal users cannot run realplayer.

Version-Release number of selected component (if applicable):
realplayer-10.0.4-1

How reproducible:
Always

Steps to Reproduce:
1. set umask to 0077
2. run "up2date realplayer" (assuming you belong to the proper channel in RHN)
3. notice that /usr/lib/helix permissions are 0700
  

Actual Results:  Realplayer is installed but the permissions on /usr/lib/helix are 0700.  As a result, normal users cannot run realplayer.

Expected Results:  Realplayer should be installed and normal users should be able to run it (without modifying directory permissions as root).

Additional info:

Comment 1 RHEL Product and Program Management 2007-10-19 19:04:18 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Comment 2 Jeremy Dreese 2007-10-19 19:49:11 UTC
I reported this bug in April 2005 when RHEL 3 was still fully maintained (i.e.
normal bug fixes were still being issued).  There was no action for over two
years, and now that RHEL 3 has entered maintenance phase, someone finally
responds to tell me that it won't be fixed.  This issue may in fact be fixed
already; I don't know.  But I do feel that it is very poor form to not respond
for such a long time, and then only to respond that it won't be fixed because
the product has entered maintenance mode.


Note You need to log in before you can comment on or make changes to this bug.