Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155559 - /usr/bin/floppy is not configured
Summary: /usr/bin/floppy is not configured
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-21 13:35 UTC by David Balažic
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-30 14:22:02 UTC


Attachments (Terms of Use)

Description David Balažic 2005-04-21 13:35:20 UTC
Description of problem:

# floppy -f /dev/hdd
floppy 0.12 Copyright 2001, Double Precision, Inc.

floppy: device /dev/hdd not found in /etc/floppy


It also fails for /dev/fd0
/dev/hdd is an LS-120 ide floppy device


Version-Release number of selected component (if applicable):

util-linux-2.12p-5

How reproducible:
  always

Steps to Reproduce:
  1. try the above command
  
Actual results:
  See above

Expected results:
  Formats the floppy medium without errors.

Comment 1 Karel Zak 2005-04-21 13:59:58 UTC
Can you try "floppy -p"?

You have to add /dev/hdd to /etc/floppy. The command "floppy" doens't work
without configuration. It's feature.

man floppy:
   A configuration file, /etc/floppy must be created before floppy can format
   floppy disks.

floppy --createrc >/etc/floppy

Comment 2 David Balažic 2005-04-21 16:05:58 UTC
... doens't work ... It's feature.
I'll have to remember that one. ;-)

Why isn't the /etc/floppy creation done at package install ?
Besides, if it can figure out the drives on it's own, why is a config file
needed at all ?

Comment 3 Karel Zak 2005-04-22 08:44:37 UTC
Does it work if you create config file?

Comment 4 David Balažic 2005-04-26 07:55:47 UTC
More or less :

I created the /etc/floppy file (it detects /dev/fd0 and /dev/hdd)
Then :

[root@localhost ~]# floppy --eject /dev/hdd
floppy 0.12 Copyright 2001, Double Precision, Inc.

ide-floppy: hdd: I/O error, pc = 1b, key =  5, asc = 24, ascq =  0

( the floppy was not ejected. Ejecting works with KNOPPIX v3.7)

[root@localhost ~]# floppy  -f A:
floppy 0.12 Copyright 2001, Double Precision, Inc.

/dev/fd0H1440: No such file or directory
No formattable capacities for /dev/fd0

[root@localhost ~]# floppy  -f /dev/fd0
floppy 0.12 Copyright 2001, Double Precision, Inc.

/dev/fd0H1440: No such file or directory
No formattable capacities for /dev/fd0

--

formatting in /dev/hdd (B:) works, it seems
but gives this error at the end :
hdd: irq timeout: status=0xc0 { Busy }
ide: failed opcode was: unknown
hdd: ATAPI reset complete

but the floppy seems to be formatted OK


Should I open new bugs for those problems ?

Comment 5 Karel Zak 2005-09-23 08:56:41 UTC
I seems like kernel error reports. I could be HW problem. Do you have this
problem with all floppy medias?

Comment 6 David Balažic 2005-09-23 09:01:56 UTC
Both drives work just fine under Windows and linux.

Note: the ejecting problem is probably a kernel bug. See bug #158548

Comment 7 Karel Zak 2005-09-23 15:35:40 UTC
Thanks.

Comment 8 David Balažic 2005-09-23 15:38:37 UTC
What you fixed it ?
(formatting fails etc)

Comment 10 Dave Jones 2005-09-28 09:57:01 UTC
are you sure you're using the right tool  ? The man page for floppy sounds scary..

       NOTE: Use caution in formatting anything other than standard 3.5" 1.4MB
floppy  disks  in  ATAPI  IDE
       floppy  drives. Most LS-120 drives, for example, accept a request to
format 120MB high density disks,
       but most 120MB disks are not designed to be formatted. Low-level
formatting  will  ruin  them  permanently.


Do you really want to do this ? You should be able to just mkfs them to get them
usable.


Comment 11 David Balažic 2005-09-28 10:32:24 UTC
I used a standard 1.4MB floppy disk, so that warning does not apply.

Comment 12 Dave Jones 2005-09-30 06:32:08 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.


Comment 13 David Balažic 2005-09-30 07:30:26 UTC
This is not kernel related.

Comment 14 Karel Zak 2005-09-30 08:33:23 UTC
David, send a patch, please. It seems that you good know where is a problem.

Comment 15 David Balažic 2005-09-30 08:54:40 UTC
Are you being sarcastic ?

"fdformat /dev/fd0" works
"floppy  -f /dev/fd0" fails

Looks like a problem in the "floppy" utility to me.

(does "floppy  -f /dev/fd0" work on your system ?)

Comment 16 Karel Zak 2005-09-30 10:38:21 UTC
It works if you create device by floppy size. The floppy util is not enough
clever to use generic floppy device (e.g. /dev/fd0). I will try to fix it. Sorry.

# MAKEDEV fd0H1440
# floppy  -f /dev/fd0
floppy 0.12 Copyright 2001, Double Precision, Inc.

Formatting 1.40 Mb... 100%

Comment 17 Karel Zak 2005-09-30 14:22:02 UTC
Fixed. Update to util-linux-2.12p-9.12.


Note You need to log in before you can comment on or make changes to this bug.