Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155536 - External USB drive produces scsi errors and won't mount
Summary: External USB drive produces scsi errors and won't mount
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-21 08:25 UTC by Simon Andrews
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-03 00:26:13 UTC


Attachments (Terms of Use)
Portion of /var/log/messages when attaching the drive running 2.6.10-1.770_FC3smp (deleted)
2005-04-21 08:29 UTC, Simon Andrews
no flags Details
Log from a different machine running 2.6.11 (deleted)
2005-04-21 08:43 UTC, Simon Andrews
no flags Details
Contents of /proc/bus/usb/devices (deleted)
2005-06-22 11:49 UTC, Simon Andrews
no flags Details
/var/log/messages under 2.6.12-1.372_FC3 (deleted)
2005-07-20 13:53 UTC, Simon Andrews
no flags Details

Description Simon Andrews 2005-04-21 08:25:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
When trying to use a LaCie external USB HDD the drive is recognised by the kernel, but fails to initialise properly.  The kernel reports a series of SCSI errors.  2.6.10 kernels will intitialise the drive and assign a device, but will then fail when trying to mount it.

Using the same drive under Knoppix and a 2.4 series kernel works fine.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.11-1.14_FC3 and 2.6.10-1.770_FC3smp

How reproducible:
Always

Steps to Reproduce:
1.Plug in a LaCie external USB HDD
2.Watch /var/log/messages
3.
  

Actual Results:  Lots of errors, and a drive which wouldn't initialise or mount.

Expected Results:  The drive should be recognised properly

Additional info:

I'll attach the relevant portions of the logs...

Comment 1 Simon Andrews 2005-04-21 08:29:56 UTC
Created attachment 113458 [details]
Portion of /var/log/messages when attaching the drive running 2.6.10-1.770_FC3smp

Comment 2 Simon Andrews 2005-04-21 08:43:58 UTC
Created attachment 113459 [details]
Log from a different machine running 2.6.11

Comment 3 Simon Andrews 2005-04-21 08:45:57 UTC
Just for the record, all machines are fully up to date FC3, with:

udev-039-10.FC3.7
hal-0.4.7-1.FC3
hotplug-2004_04_01-8.1


Comment 4 Pete Zaitcev 2005-06-11 04:39:11 UTC
That wild block number is a good hint. I saw it before, but cannot remember
where. I thought we stopped supporting the EFI (EPP?) partitioning, which
was one thing reading that far. Curious.

May I see /proc/bus/usb/devices? It's best to attach it.


Comment 5 Simon Andrews 2005-06-22 11:49:40 UTC
Created attachment 115806 [details]
Contents of /proc/bus/usb/devices

I've now tried this on a new FC4 system with similar results.  This file was
captured from FC4

Comment 6 Dave Jones 2005-07-15 17:56:56 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 7 Simon Andrews 2005-07-20 13:53:50 UTC
Created attachment 116975 [details]
/var/log/messages under 2.6.12-1.372_FC3

The drive still doesn't work under the latest FC3 kernel - same kind of errors
as before.

Most of our machines have now moved to FC4 so it might be easier to change the
bug to FC4.  I can do occasional tests on an FC3 machine though

Comment 8 Dave Jones 2005-10-03 00:26:13 UTC
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.