Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155532 - Hinting should be disabled for Gujarati fonts.
Summary: Hinting should be disabled for Gujarati fonts.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Carl Worth
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-21 06:56 UTC by Ankit Patel
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.3.92.cvs20051129-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-13 23:43:37 UTC


Attachments (Terms of Use)
Show the screenshot taken with enabling hinting. (deleted)
2005-05-16 05:28 UTC, Ankit Patel
no flags Details
Show the screenshot taken with disabling hinting. (deleted)
2005-05-16 05:33 UTC, Ankit Patel
no flags Details
Normal fonts with hinting enabled. (deleted)
2005-05-16 08:33 UTC, Ankit Patel
no flags Details
Normal fonts with hinting disabled. (deleted)
2005-05-16 08:34 UTC, Ankit Patel
no flags Details

Description Ankit Patel 2005-04-21 06:56:28 UTC
Description of problem:
Hinting for Gujarati fonts is Enabled by default. It should be disabled.

Version-Release number of selected component (if applicable):


How reproducible:
Anytime when you login in gujarati interface, you will get hinting enabled.

Steps to Reproduce:
1.Login in Gujarati interface
2.check the look of the fonts
3.check the file /etc/fonts/fonts.conf
  
Actual results:
Fonts are not looking good. In /etc/fonts/fonts.conf file hinting is not false
for gujarati.

Expected results:
Fonts should look good. In /etc/fonts/fonts.conf file hinting should be false
for gujarati.

Additional info:

Comment 1 Leon Ho 2005-05-16 05:15:16 UTC
Runa mentioned the new testing font is good with hinting now on Bengali. Is it
true for Gujarati?

Comment 2 Ankit Patel 2005-05-16 05:21:02 UTC
No not good with hinting. If hinting is disabled then it looks better. I will
attach the screenshot soon...

Comment 3 Ankit Patel 2005-05-16 05:28:38 UTC
Created attachment 114409 [details]
Show the screenshot taken with enabling hinting.

When you enable hinting then some characters get distorted. In this screenshot
i have pointed a single word only, but there are more characters which have
distortion problem.

Comment 4 Ankit Patel 2005-05-16 05:33:39 UTC
Created attachment 114410 [details]
Show the screenshot taken with disabling hinting.

When you disable hinting then you can find the character better...

Comment 5 Leon Ho 2005-05-16 05:57:00 UTC
Ankit, is it only happen in Bold font? Because we cannot include bold font yet
(printing problems #137790)

So the question currently is, does regular font better with hinting or no-hinting?

Comment 6 Ankit Patel 2005-05-16 08:27:50 UTC
It happen to regular font also. So finally regular font better with no-hinting.

Comment 7 Ankit Patel 2005-05-16 08:33:56 UTC
Created attachment 114413 [details]
Normal fonts with hinting enabled.

Comment 8 Ankit Patel 2005-05-16 08:34:37 UTC
Created attachment 114414 [details]
Normal fonts with hinting disabled.

Comment 9 Leon Ho 2005-05-17 04:33:07 UTC
Final question, Ankit - is this issue unbearable to native Gujarati users? (i.e.
is it a MustFix for RHEL4 as oppose to fixing it in future version like next FC
and onwards?)

Comment 10 Ankit Patel 2005-05-17 05:17:48 UTC
It's not that much critical, We can fix this in the future version, may be next
FC...

Comment 11 Leon Ho 2005-05-18 06:30:17 UTC
Thanks, okay moving to Fedora Core and to the right component.

Comment 12 Carl Worth 2005-12-13 23:43:37 UTC
This should be fixed now:

        * Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
        - Disable hinting for Lohit Gujarati

But please double-check, (I don't actually have this font to test with).

I've also committed a fix for this upstream in fontconfig.

-Carl


Note You need to log in before you can comment on or make changes to this bug.