Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155522 - system-config-network-tui will not change eth0 from dhcp to static
Summary: system-config-network-tui will not change eth0 from dhcp to static
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-network
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 168429
TreeView+ depends on / blocked
 
Reported: 2005-04-21 01:51 UTC by David Kewley
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0094
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-07 18:38:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0094 qe-ready SHIPPED_LIVE system-config-network bug fix update 2006-03-06 05:00:00 UTC

Description David Kewley 2005-04-21 01:51:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040920

Description of problem:
I installed a new no-X server with eth0 on dhcp for convenience.  Now that I have a static address for it, I am trying to use system-config-network (-tui) to change it to static.

As you'll see from the details below, it looks like system-config-network-tui is borked in more than one way (specifically in this case, failing to change ifcfg-eth0 as requested (indeed its mtime is left the same); instead, changing the mtime on ifcfg-eth1).


Version-Release number of selected component (if applicable):
system-config-network-tui-1.3.22-1

How reproducible:
Always

Steps to Reproduce:
* run system-config-network (-tui screen comes up)
* select Ethernet
* click OK
* change Name and Device fields from eth1 and eth1 (or other randomly-initialized eth{0,1} combinations) to eth0 and eth0
* unselect Use DHCP
* enter all three fields of address information
* click OK
* back on start screen, click Exit



Actual Results:  Now check what happened in /etc/sysconfig/network-scripts:

* ifcfg-eth0 is unchanged (same modtime as before)
* ifcfg-eth1 is changed, and now contains this info (MAC obscured):

DEVICE=eth0
HWADDR=aa:bb:cc:dd:ee:ff
ONBOOT=yes
TYPE=Ethernet
BOOTPROTO=dhcp

An ifdown eth0 ; ifup eth0 shows eth0 re-negotiating a DHCP address (it gets the same address as before in this particular trial).

Expected Results:  /etc/sysconfig/network-scripts/ifcfg-eth1 would be unchanged (in this example it is an unused interface; I don't know what would have happened if it had been in use)

/etc/sysconfig/network-scripts/ifcfg-eth0 would have the correct, new static IP information

ifdown eth0 ; ifup eth0 would result in eth0 using its new static IP address properly

Additional info:

I'm just going to edit the ifcfg-ethN files by hand, obviously.  But it'd be nice if people using RHEL 4 AS on "Advanced Servers" (with no X) could actually use the provided tool.

Comment 8 Harald Hoyer 2005-09-09 14:11:22 UTC
Does this version fix your problems?
ftp://people.redhat.com/harald/system-config-network/1.3.22.0.EL.4.1-1/

Comment 14 Red Hat Bugzilla 2006-03-07 18:37:17 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0094.html


Comment 15 Red Hat Bugzilla 2006-03-07 18:37:40 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0094.html


Comment 16 Red Hat Bugzilla 2006-03-07 18:38:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0094.html



Note You need to log in before you can comment on or make changes to this bug.