Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155521 - ERROR: /sbin/udevstart exited abnormally
Summary: ERROR: /sbin/udevstart exited abnormally
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-21 01:39 UTC by Doug Henderson
Modified: 2007-11-30 22:11 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 11:50:55 UTC


Attachments (Terms of Use)
normal log file (deleted)
2005-04-21 01:40 UTC, Doug Henderson
no flags Details
2.6.11-1.1251_FC4 lsmod output (deleted)
2005-04-21 01:42 UTC, Doug Henderson
no flags Details

Description Doug Henderson 2005-04-21 01:39:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
Immediatly after the "Red Hat nash version 4.2.8 starting" line, I see two messages like:

ERROR: /sbin/udevstart exited abnormally! (pid 447)
ERROR: /sbin/udevstart exited abnormally! (pid 466)

I don't see any obvious consequences, unless it the odd behavior of my optical drive - there are messages about "cdrom: open failed" - and the package manager would not recognize a disk.



Version-Release number of selected component (if applicable):
kernel 2.6.11-1.1251_FC4, udev-057-1

How reproducible:
Always

Steps to Reproduce:
1. reboot
  

Actual Results:  Message always appear.

Additional info:

Comment 1 Doug Henderson 2005-04-21 01:40:41 UTC
Created attachment 113453 [details]
normal log file

This is what my log file looks like following a normal successful reboot.

Comment 2 Doug Henderson 2005-04-21 01:42:10 UTC
Created attachment 113454 [details]
2.6.11-1.1251_FC4 lsmod output

output from lsmod command.

Comment 3 Yao Zhang 2005-04-21 16:50:11 UTC
I have seen it too with FC devel.

Right before the line

ERROR: /sbin/udevstart exited abnormally!

There are two lines

mknod: Failed to create /dev/null
mknod: Failed to create /dev/console

Not sure if they are related.  Those error messages are not found in
any log file though, only appear on screen.

Comment 4 Harald Hoyer 2005-04-21 17:23:17 UTC
hmm, sounds like the initrd mknod has problems

Comment 5 Doug Henderson 2005-04-22 04:05:38 UTC
problem occurs with 1253 build

Comment 6 Harald Hoyer 2005-04-22 07:42:44 UTC
is selinux turned on?
is /dev mounted with a tmpfs? (cat /proc/mounts)

Comment 7 Doug Henderson 2005-04-22 12:31:17 UTC
selinux is on

[doug@lambda ~]$ cat /proc/mounts
rootfs / rootfs rw 0 0
none /dev tmpfs rw 0 0
/dev/root / ext3 rw 0 0
none /selinux selinuxfs rw 0 0
/proc /proc proc rw,nodiratime 0 0
/proc/bus/usb /proc/bus/usb usbfs rw 0 0
/sys /sys sysfs rw 0 0
none /dev/pts devpts rw 0 0
/dev/hda2 /boot ext3 rw 0 0
none /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0

I upgraded this system from a fully updated FC3 with the FC4test2 CDs.


Comment 8 Gene Czarcinski 2005-04-22 19:47:41 UTC
Updated hardware=all since I am seeing this on an Opteron (x86_64).

Comment 9 Tom Diehl 2005-04-22 20:00:05 UTC
I did a full update from rawhide today and I too am still seeing the above
errors.  Selinux is on. Do you need any further info?

Comment 10 Doug Henderson 2005-04-22 23:43:08 UTC
After installing all updates, including 
kernel 2.6.11-1.1258_FC4 
udev-057-2

the problem is still present. Messages are

ERROR: /sbin/udevstart exited abnormally! (pid 407)
ERROR: /sbin/udevstart exited abnormally! (pid 426)

also there are two other messages which appear on the console but are not logged

unmounting old /proc
unmounting old /sys



Comment 11 James Morris 2005-04-23 01:32:41 UTC
I'm seeing this with selinux=0

Comment 12 Lars G 2005-04-23 05:53:38 UTC
i get this too with selinux disabled.

Comment 13 Kjartan Maraas 2005-04-27 00:07:53 UTC
This is still happening with rawhide from today. I get the same errors as above
and mknod says it has problems creating /dev/null, /dev/console and /dev/zero

Comment 14 Alexandre Oliva 2005-04-27 01:54:54 UTC
I've had such problems, but they appear to be somewhat random.  After I updated
to today's rawhide, the kernel wouldn't boot: after a number of failed mknods,
switchroot failed.  Another reboot still had some failed mknods, but it booted.

Comment 15 Peter Jones 2005-04-27 05:09:13 UTC
Try the mkinitrd and udev from rawhide as of 4/27 .  Hopefully fixed.

If it's not, please change this back to "ASSIGNED".

Comment 16 Kjartan Maraas 2005-04-27 20:01:56 UTC
I don't get the udevstart errors any longer after today's yum update, but I
still see it failing to create /dev/zero and /dev/null

Comment 17 Doug Henderson 2005-04-28 04:50:39 UTC
The error messages have disappeared with kernel 2.6.11-1.1268_FC4.

Comment 18 Alexandre Oliva 2005-05-04 17:27:15 UTC
It no longer exits with a non-zero status, but it still randomly displays
messages about failure to mknod devices such as /dev/zero.  It's not reliably
reproducible, and the actual set of mknod errors varies.  This is with a fresh
install of FC4-re0503.0.

Comment 19 Peter Jones 2005-05-06 02:15:34 UTC
Alexandre, can you tell me what you see before and after those lines?  I'm
wondering if this morning's udev would fix it, but I'm not seeing this problem
on any of my machines.


Comment 20 Alexandre Oliva 2005-05-06 17:52:05 UTC
This is what I got on FC4-re0505.0 (x86_64):

audit (...): initialized
Red Hat nash v. ...  starting
mknod: ... /dev/zero: 17
[messages about sda and sdb that I get when sbp2 and usb-storage are loaded]
Reading all physical volumes...

The odd thing is that the messages are random; sometimes there are none,
sometimes there are messages for all 3 mknod commands in the init script in
initrd, in the right order.  This points to nash's mknod or the kernel as the
prime suspects, I think.

Comment 21 Harald Hoyer 2005-05-09 11:50:55 UTC
then please open a new bugzilla for the problem

Comment 22 Alexandre Oliva 2005-05-22 06:07:56 UTC
Done.  For reference, it's now Bug 158427.


Note You need to log in before you can comment on or make changes to this bug.