Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155516 - Warnings printed to console
Summary: Warnings printed to console
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 23:54 UTC by Phil Muldoon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-26 20:01:54 UTC


Attachments (Terms of Use)

Description Phil Muldoon 2005-04-20 23:54:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
When starting eclipse, warnings are printed to the console:

Warnings while parsing the commands from the 'org.eclipse.ui.commands' and 'org.eclipse.ui.actionDefinitions' extension points.
Reason:
Warnings while parsing the commands from the 'org.eclipse.ui.commands' and 'org.eclipse.ui.actionDefinitions' extension points.

Version-Release number of selected component (if applicable):
M6.7

How reproducible:
Always

Steps to Reproduce:
1. Start native eclipse
2.
3.
  

Actual Results:  Warnings printed

Expected Results:  Clean console

Additional info:

Comment 1 Andrew Overholt 2005-04-26 16:30:57 UTC
I can't duplicate this.  Phil, is it still happening for you in 3.1.0_fc-0.M6.11
and gcc*-4.0.0-1?

Comment 2 Phil Muldoon 2005-04-26 17:25:05 UTC
Yes, I still see this. 

rpm -q eclipse-platform
eclipse-platform-3.1.0_fc-0.M6.11

rpm -q gcc
gcc-4.0.0-1

I removed .eclipse and moved my old workspace out of the way. Warnings still
printed.

Basically, from the gnome terminal type:

eclipse

Eclipse will actually run and load fine, but the following will be printed to
the gnome console; the message is printed twice:


Warnings while parsing the commands from the 'org.eclipse.ui.commands' and
'org.eclipse.ui.actionDefinitions' extension points.
Reason:
Warnings while parsing the commands from the 'org.eclipse.ui.commands' and
'org.eclipse.ui.actionDefinitions' extension points.

Shall I do a complete new reinstall of Eclipse? I've upgraded this eclipse via
yum multiple times.



Comment 3 Andrew Overholt 2005-04-26 17:51:48 UTC
It's weird that you get it and I don't.  Does it happen for you with a
proprietary JVM as well?

Comment 4 Phil Muldoon 2005-04-26 18:35:57 UTC
/usr/sbin/update-alternatives --display java

java - status is manual.
 link currently points to /usr/lib/jvm/java-1.4.2-ibm-1.4.2.1/jre/bin/java

I get the same messages. 

However if I download and use:

eclipse-SDK-3.1M6-linux-gtk.tar.gz

I do not get that message.



Comment 5 Phil Muldoon 2005-04-26 20:01:54 UTC
I cannot reproduce on a cleanly installed system. I'll just chalk it up to
corruption/mis-configuration on this system. I'll close it for now; we can
reopen if it occurs somewhere else.


Note You need to log in before you can comment on or make changes to this bug.