Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155515 - nv server only shows vertical lines
Summary: nv server only shows vertical lines
Keywords:
Status: CLOSED DUPLICATE of bug 157715
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 23:49 UTC by Dan Christian
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-29 08:39:30 UTC


Attachments (Terms of Use)
Complete server startup log (deleted)
2005-04-29 16:54 UTC, Dan Christian
no flags Details
X configuration file (deleted)
2005-04-29 17:23 UTC, Dan Christian
no flags Details

Description Dan Christian 2005-04-20 23:49:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Fedora/1.7.6-1.2.5

Description of problem:
When the "nv" video server is configured, it only shows mostly green vertical lines on a black background.  The text consoles are also corrupted (white lines on a black background).  You have to reboot to restore the display.

The driver correctly identifies the card as a GeForce 6600 GT.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-25

How reproducible:
Always

Steps to Reproduce:
1. Change driver from "vesa" to "nv"
2. Start X server
3.
  

Additional info:

Select entries from Xorg.0.log:

(II) Module int10: vendor="X.Org Foundation"
        compiled for 6.8.2, module version = 1.0.0
        ABI class: X.Org Video Driver, version 0.7
(II) NV(0): Initializing int10
(WW) NV(0): Bad V_BIOS checksum
(II) NV(0): Primary V_BIOS segment is: 0xc000
(--) NV(0): Chipset: "GeForce 6600 GT"
(**) NV(0): Depth 24, (--) framebuffer bpp 32
(==) NV(0): RGB weight 888
(==) NV(0): Default visual is TrueColor
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib64/modules/libvgahw.a
(II) Module vgahw: vendor="X.Org Foundation"
        compiled for 6.8.2, module version = 0.1.0
        ABI class: X.Org Video Driver, version 0.7
(==) NV(0): Using HW cursor
(--) NV(0): Linear framebuffer at 0xE0000000
(--) NV(0): MMIO registers at 0xFB000000
...
(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        8x8 mono pattern filled rectangles
        Indirect CPU to Screen color expansion
        Solid Lines
        Scanline Image Writes
        Offscreen Pixmaps
        Setting up tile and stipple cache:
                32 128x128 slots
                32 256x256 slots
                16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(**) Option "dpms"
(**) NV(0): DPMS enabled
(==) RandR enabled

Comment 1 Dan Christian 2005-04-20 23:51:49 UTC
Wrong release.  Should be FC4-test2.


Comment 2 Mike A. Harris 2005-04-29 12:53:35 UTC
Please attach the complete X server log file and config file as bugzilla
file attachments (not cut and paste).

Comment 3 Dan Christian 2005-04-29 16:54:25 UTC
Created attachment 113857 [details]
Complete server startup log

Comment 4 Dan Christian 2005-04-29 17:23:35 UTC
Created attachment 113859 [details]
X configuration file

Comment 5 Dan Christian 2005-05-29 03:37:21 UTC
I installed an Athlon (Sempron) system running FC3 with an identical board, and
it acts the same way.

The Xorg release notes say that the chip is supported.  There must be something
about the board.  This is a BFG Tech 6600 GTOC.


Comment 6 Mike A. Harris 2005-05-29 08:39:30 UTC

*** This bug has been marked as a duplicate of 157715 ***


Note You need to log in before you can comment on or make changes to this bug.