Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155498 - avc denied with ntpd and targeted policy
Summary: avc denied with ntpd and targeted policy
Keywords:
Status: CLOSED DUPLICATE of bug 154759
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 21:18 UTC by Aurelien Bompard
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-21 14:45:19 UTC


Attachments (Terms of Use)

Description Aurelien Bompard 2005-04-20 21:18:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
ntpd won't start on kernel 2.6.11-1.14_FC3 with the targeted policy from selinux-policy-targeted-1.17.30-2.96.
In the logs I get :
ntpd[9190]: ntpd 4.2.0a@1.1190-r Mon Oct 11 09:10:20 EDT 2004 (1)
ntpd[9190]: precision = 4.000 usec
ntpd[9190]: Listening on interface wildcard, 0.0.0.0#123
ntpd[9190]: Listening on interface wildcard, ::#123
ntpd[9190]: Listening on interface lo, 127.0.0.1#123
ntpd[9190]: Listening on interface eth0, my.public.ip.address#123
ntpd[9190]: Listening on interface eth1, 192.168.1.1#123
ntpd[9190]: kernel time sync status 0040
kernel: audit(1114015098.816:0): avc:  denied  { dac_override } for  pid=9190 exe=/usr/sbin/ntpd capability=1 scontext=root:sys
tem_r:ntpd_t tcontext=root:system_r:ntpd_t tclass=capability

And:
# ntpd -d
Segmentation fault

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.96 ntp-4.2.0.a.20040617-4 kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1. start ntpd, either with 'ntpd' or 'service ntp start'  

Additional info:

Comment 1 Hans Ecke 2005-04-21 00:09:08 UTC
I bet this a duplicate of bug #154759 

Comment 2 Daniel Walsh 2005-04-21 12:11:26 UTC
Can you get an strace of this.  It is trying to change the DAC of some file?

Dan

Comment 3 Daniel Walsh 2005-04-21 14:45:19 UTC

*** This bug has been marked as a duplicate of 154759 ***


Note You need to log in before you can comment on or make changes to this bug.