Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155497 - interfaces aliases with ONBOOT=no are brought up anyway
Summary: interfaces aliases with ONBOOT=no are brought up anyway
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts
Version: 3.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 179065 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 21:01 UTC by Cove Schneider
Modified: 2014-03-17 02:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-20 21:06:46 UTC


Attachments (Terms of Use)

Description Cove Schneider 2005-04-20 21:01:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/312.1 (KHTML, like Gecko) Safari/312

Description of problem:
ONBOOT=no is ignored on eth0:x interface aliases. If you have ifcfg-eth0 and ifcfg-eth0:0, where 
ifcfg-eth0:0 has ONBOOT=no set, eth0:0 is brought up anyway at boot.

Version-Release number of selected component (if applicable):
initscripts-7.31.18.EL-1

How reproducible:
Always

Steps to Reproduce:
1. Copy /etc/sysconfig/network-scripts/ifcfg-eth0 to /etc/sysconfig/network-scripts/ifcfg-eth0:0
2. Change the IP address in ifcfg-eth0:0 and set ONBOOT=no
3. Reboot machine
  

Actual Results:  Interface eth0:0 is brought up after boot.

Expected Results:  Interface eth0:0 should be down after boot.

Additional info:

Comment 1 Bill Nottingham 2005-04-20 21:06:46 UTC
Alias interfaces are controlled by ONPARENT, not ONBOOT.

This is documented in sysconfig.txt as of 7.31.11.EL-1 and later.

Comment 2 Cove Schneider 2005-04-20 21:24:04 UTC
Oh, I see. Sorry for misunderstanding your previous note. IMHO, it may be help for busy admins to have 
ONBOOT also work for interface alias, rather silently ignoring it. Unfortunately I had a service outage 
today due to thinking that ONBOOT would work in an alias file. I didn't know to look in /usr/share/doc/
initscripts-7.31.18.EL/sysconfig.txt.

Comment 3 Bill Nottingham 2006-01-27 20:19:03 UTC
*** Bug 179065 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.