Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155489 - Bad: foomatic-3.0.2-13.4 breaks printing on HP PSC750xi
Summary: Bad: foomatic-3.0.2-13.4 breaks printing on HP PSC750xi
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: foomatic
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 20:08 UTC by Alfredo Ferrari
Modified: 2008-02-08 03:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-08 03:20:18 UTC


Attachments (Terms of Use)
output of printconf-tui --Xexport (deleted)
2005-04-21 18:42 UTC, Alfredo Ferrari
no flags Details

Description Alfredo Ferrari 2005-04-20 20:08:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
After installation of foomatic-3.0.2-13.4, whichever printing attempt on a HP PSC750xi results in the postscript text being printed (I mean the ASCII of the
postscript file in endless pages) rather than being "interpreted" (that is getting for example the test page with the redhat logo etc)

I tried to reboot/restart cups etc, no way. Downgrading to foomatic-3.0.2-13.3 fixes immediately the problem

Since this is the only printer I have available at the moment, I do not know if it is a general problem a problem specific of printers printing thru hpoj,
or specific of this model/driver only

Version-Release number of selected component (if applicable):
3.0.2-13.4

How reproducible:
Always

Steps to Reproduce:
1.upgrade to foomatic-3.0.2-13.4
2.try to print a postscript file (or the test page) on a HP PSC750xi
3.look at the result
  

Actual Results:  a lot of garbage pages are printed

Expected Results:  the usual test page should come out

Additional info:

Comment 1 Tim Waugh 2005-04-21 09:09:35 UTC
Please attach the output of 'printconf-tui --Xexport'.  Thanks.

Comment 2 Alfredo Ferrari 2005-04-21 18:42:00 UTC
Created attachment 113481 [details]
output of printconf-tui --Xexport

This is the output of printconf-tui --Xexport (with foomatic-3.0.2-13.4
installed). Let me know if I can be of further help

Comment 3 Tim Waugh 2005-04-22 09:14:52 UTC
I can't reproduce this problem here.  hpoj is working as normal for me, and
redirecting the output to a temporary file after importing your configuration
results in the expected binary data, not the PostScript you see.

How are you printing files?

It would be useful to see the cups error_log after you've set 'LogLevel debug2'
in /etc/cups/cupsd.conf, restarted cups, and printed again.

Comment 4 Alfredo Ferrari 2005-04-22 10:50:22 UTC
Thanks for your help. I'll set LogLevel debug2 and try again (this evening,
the printer is my home printer). I started to notice the problem printing from
OpenOffice a two page, text only document. I got garbage starting with 

%!PS-Adobe-3.0  etc etc getting printed instead of the document.

I restarted hpoj, lpd, printed to a file, looked at the file and then printed
with lpr. Same result. I rebooted the machine (useless I know), opened a pdf
with acroread and printed, same result. At this point I entered the printer
configuration tool and printed the A4 postscript test page from the "test" radio
button. I downgraded foomatic, printed a test page again, it came out perfect.
I installed again foomatic-3.0.2-13.4 and tried to print a test page, garbage
again, downgraded again -> no problem. At this point I opened the bug. Let me
know if I can be of further help


Comment 5 Matthew Miller 2006-07-10 23:09:45 UTC
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!


Comment 6 petrosyan 2008-02-08 03:20:18 UTC
Fedora Core 3 is not maintained anymore.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.


Note You need to log in before you can comment on or make changes to this bug.