Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155487 - Segmentation faults in Perl_gv_fetchpv() and Perl_find_script()
Summary: Segmentation faults in Perl_gv_fetchpv() and Perl_find_script()
Keywords:
Status: CLOSED DUPLICATE of bug 155490
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 19:57 UTC by Hans Ecke
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-20 20:12:02 UTC


Attachments (Terms of Use)

Description Hans Ecke 2005-04-20 19:57:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; en_US) KHTML/3.4.0 (like Gecko)

Description of problem:
Recently I have seen segmentation faults crop up in unattended (cron) perl  
scripts. Unfortunately I can not reproduce them interactively. 
  
I set them to create core files and downloaded perl-debuginfo. Attached you 
will find some backtraces that might help.   

Version-Release number of selected component (if applicable):
perl-5.8.5-9

How reproducible:
Sometimes

Steps to Reproduce:
1.Have perl scripts in cron (/etc/cron.hourly/ etc) 
2.Use BSD::Resource to make them create core files if interrupted 
3.Wait for messages in the mail 
   

Actual Results:  Perl scripts die from segmentation fault and create core files 

Expected Results:  They should not die. Perl should never ever see a segfault. 

Additional info:

See attached gdb backtraces.

Comment 1 Hans Ecke 2005-04-20 20:12:02 UTC
Double "submit", deleting this copy  

*** This bug has been marked as a duplicate of 155490 ***


Note You need to log in before you can comment on or make changes to this bug.