Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155483 - Graphical installation fails on Power Book G4
Summary: Graphical installation fails on Power Book G4
Keywords:
Status: CLOSED DUPLICATE of bug 149188
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 19:23 UTC by Quereller
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-29 07:43:41 UTC


Attachments (Terms of Use)

Description Quereller 2005-04-20 19:23:48 UTC
Description of problem:
The graphical installation on a 12" Power Book G4 with Nvidia Card fails.

From /tmp/ramfs/X.log: Fatal Server error: Caught signal 11. Server aborting

Version-Release number: 6.8.2

How reproducible: always



Additional Info:
Video-Card: GeForce FX Go5200
X Server uses Framebuffer

When i try to start the xserver manualy i get also the error 
(EE) FBDEV(0): FBIOPAN_DISPLAY: Invalid agument

When I change fbdev to nv in XConfig.test the server works as expected

Comment 1 Mike A. Harris 2005-04-29 07:26:06 UTC
This problem occured before a long time ago, perhaps 2 or more years ago
on ppc, and if I'm not mistaken, it was a bug in the ppc kernel fb code.

I believe our installer defaults to using "fbdev" because our PPC stuff
is really developed for IBM pSeries/iSeries where fbdev is necessary.
While I think this default needs to remain there for IBM hardware, I
think the default for Fedora should be the native video drivers.

Perhaps our config tool should use dmidecode to determine if it is running
on IBM server or Mac hardware?  No idea if that's a good idea or not.

Reassigning to kernel component for fbdev issue.

Comment 2 David Woodhouse 2005-04-29 07:43:41 UTC
Just another "we don't set up X right on Macs" dup, I think.

*** This bug has been marked as a duplicate of 149188 ***


Note You need to log in before you can comment on or make changes to this bug.