Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155457 - SCSI scanner detected 64 times after kernal upgrade
Summary: SCSI scanner detected 64 times after kernal upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL: None
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 15:16 UTC by Jerry Barrington
Modified: 2015-01-04 22:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-08 23:01:04 UTC


Attachments (Terms of Use)

Description Jerry Barrington 2005-04-20 15:16:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3) Gecko/20030313

Description of problem:
After upgrading the kernal via up2date, the single connected and powered up SCSI 
scanner is detected at bootup 64 times ( as /dev/sg0 through /dev/sg63 ).

Version-Release number of selected component (if applicable):
kernal2.6.11-1.14_FC3 and kernal 2.6.10-1.770_FC3

How reproducible:
Always

Steps to Reproduce:
1.Turn on scanner
2.Boot the system
3.Check hardware manager
  

Actual Results:  /dev/sg0 through /dev/sg63 are listed in the scanners section and no scanning can
be done.  This was tried with Gimp.

Expected Results:  /dev/sg0 should be the only one seen.

Additional info:

To correct the problem, boot again with the scanner off and unconfigure the scanner.  Then turn on the scanner and boot with kernal 2.6.9-1.667. configure
the scanner again snd all works correctly.

Comment 1 Dave Jones 2005-04-20 20:12:07 UTC
can you attach the output of /proc/scsi/scsi please ?

Comment 2 Jerry Barrington 2005-04-29 05:47:36 UTC
(In reply to comment #1)
> can you attach the output of /proc/scsi/scsi please ?

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 01
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 02
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 03
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 04
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 05
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 06
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 07
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 08
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 09
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 10
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 11
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 12
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 13
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 14
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 15
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 16
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 17
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 18
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 19
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 20
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 21
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 22
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 23
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 24
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 25
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 26
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 27
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 28
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 29
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 30
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 31
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 32
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 33
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 34
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 35
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 36
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 37
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 38
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 39
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 40
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 41
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 42
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 43
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 44
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 45
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 46
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 47
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 48
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 49
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 50
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 51
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 52
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 53
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 54
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 55
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 56
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 57
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 58
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 59
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 60
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 61
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 62
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi0 Channel: 00 Id: 00 Lun: 63
  Vendor:          Model: Scanner          Rev: 1.80
  Type:   Scanner                          ANSI SCSI revision: 04
Host: scsi1 Channel: 00 Id: 06 Lun: 00
  Vendor: IOMEGA   Model: ZIP 100          Rev: D.17
  Type:   Direct-Access                    ANSI SCSI revision: 02

Comment 3 Jerry Barrington 2005-04-29 05:49:17 UTC
This is the full file content.  Only the first and last entries are valid.


Comment 4 Dave Jones 2005-04-29 22:15:36 UTC
heh, thats a tricky one to blacklist due to the empty vendor string.
I'll see what I can do.


Comment 5 Dave Jones 2005-04-29 23:19:53 UTC
in a while a 2.6.11-1.21_FC3 kernel will appear at 
http://people.redhat.com/davej/kernels/Fedora/FC3/RPMS.kernel/

can you give that a try, and let me know if it fixes this ?


Comment 6 Jerry Barrington 2005-04-30 07:12:16 UTC
(In reply to comment #5)
> in a while a 2.6.11-1.21_FC3 kernel will appear at 
> http://people.redhat.com/davej/kernels/Fedora/FC3/RPMS.kernel/
> 
> can you give that a try, and let me know if it fixes this ?
> 

That seems to work nicely. Thank you very much.

Comment 7 Dave Jones 2005-05-01 08:04:22 UTC
great, thanks for testing. This will be included in the next update.



Note You need to log in before you can comment on or make changes to this bug.