Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155446 - ntpd randomly SIGSEGVs
Summary: ntpd randomly SIGSEGVs
Keywords:
Status: CLOSED DUPLICATE of bug 145258
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 13:10 UTC by Marco Colombo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-20 22:42:45 UTC


Attachments (Terms of Use)

Description Marco Colombo 2005-04-20 13:10:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
After updating to kernel-2.6.11-1.14_FC3 from updates, ntpd fails to restart,
as a service, or will die of SIGSEGV if launched directly. This is confirmed
on two different hosts, one is an old Athlon 700 on a AMD-751 MB, the other
one is a more recent P4 (Dell PowerEdge 750), running kernel-smp-2.6.11-1.14_FC3,
BTW.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Sometimes

Steps to Reproduce:
1. Create a small configuration file for ntpd, like this one:
cat /tmp/ntp-tmp.conf
server 0.pool.ntp.org
server 1.pool.ntp.org
server 2.pool.ntp.org

2. Depending on your selinux configuration, you may need to set the right
type:
chcon -t net_conf_t /tmp/ntp-tmp.conf

3. Run:
ntpd -q -g -c /tmp/ntp-tmp.conf


Actual Results:  [root@vis01 ~]# ntpd -q -g -c /tmp/ntp-tmp.conf
Segmentation fault

[root@srv03 ~]# ntpd -q -g -c /tmp/ntp-tmp.conf
Segmentation fault


Expected Results:  ntpd should set the date after a while (anyway, should not SIGSEGV)

Additional info:

This is a regression. I've got many hosts running either ntpd as a client
(as a replacement for ntpdate) or as a server, all tested with all kernels
from FC3 before 2.6.11-1.14_FC3. A quick test shows the problems exists
also if ntpd is used in normal daemon mode. On the P4, reverting to
2.6.10-1.770_FC3 solves the problem. The Athlon server used to run  2.6.10-1.770_FC3 just fine.

Weird enough, using strace it seems to fail at different, random, places:

run1:
read(10, "#\n# /etc/nsswitch.conf\n#\n# An ex"..., 4096) = 1686
read(10, "", 4096)                      = 0
close(10)                               = 0
munmap(0xb7ffb000, 4096)                = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

run2:
gettimeofday({1114001558, 283781}, NULL) = 0
gettimeofday({1114001558, 284029}, NULL) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

run3:
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
adjtimex({modes=61, offset=0, freq=0, maxerror=16, esterror=16, status=64, constant=0, precision=1, tolerance=33554432, time={1114001571, 330177}}) = 5rt_sigaction(SIGSYS, {SIG_DFL}, NULL, 8) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

Sometimes it even works fine. I've never managed to have it not fail
w/o strace. With strace, on the P4 it succeeds more often than on the
Athlon (I'm not implying this is anyhow useful info - just reporting
everything I noticed).

Comment 1 Marco Colombo 2005-04-20 22:42:45 UTC

*** This bug has been marked as a duplicate of 145258 ***


Note You need to log in before you can comment on or make changes to this bug.