Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155432 - OOo randomly dies
Summary: OOo randomly dies
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 09:53 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1.9.108--4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-10 15:09:09 UTC


Attachments (Terms of Use)

Description Paul F. Johnson 2005-04-20 09:53:29 UTC
Description of problem:
OOo is randomly quitting without any notice or throwback when run from the
command line or launcher

Version-Release number of selected component (if applicable):
1.9.92

How reproducible:
Very

Steps to Reproduce:
1. Use OOo writer post 19/04/05 updates
2.
3.
  
Actual results:
OOo dies randomly

Expected results:
OOo not dying randomly

Additional info:
This may be a libgcj related problem

Comment 1 Caolan McNamara 2005-04-25 08:38:06 UTC
still there in 1.9.93 ?

Comment 2 Caolan McNamara 2005-04-28 11:50:43 UTC
Seems to be gone with 1.9.96-2 and up-to-date rawhide.

Comment 3 Paul F. Johnson 2005-05-08 09:51:53 UTC
Actually, it's still there in 1.9.100-1. It seems to be that the majority of the
crashes are straight after a save (via clicking on the disc icon). There is
never any sort of warning and the file saved always has a zero bite size.

Comment 4 Srihari Vijayaraghavan 2005-05-20 13:22:04 UTC
I am not sure if my problem is similar to this, but here are the steps to
reproduce it anyway on FC4 test 3 (with all official rawhide updates as of 20
May 2005):
1. Create a new document in OO Writer
2. Leave couple of blank lines
3. Type in couple of more lines, say "Section 1" and "Section 2"
4. Format those lines as the "Heading 1".
5. Insert a Table of Contents and a page break just above those lines.
6. Insert a header and type something there.
7. Save the document.
8. Right click on the TOC, and select Update Indexes/tables..
9. The header should become invisible.
10. Now try to save the document, and observe that OO Writer crashes and leaves
a zero byte file behind.

(I lost couple of my assignments this way, but luckily I had the "auto save"
feature turned on, which saved most of my documents.)

Thanks.
Hari

Comment 5 Patrick 2005-05-20 13:25:22 UTC
I just had a similar experience as described here. Also had OOo-1.9.100-1 crash
right after a save. After the crash the document I was saving suddenly had 0
bytes length while it was 3 pages long before the crash. No harm done as I had a
backup but still. Hope this will be fixed soon.

Comment 6 Paul F. Johnson 2005-05-21 13:49:14 UTC
By the looks of it (as reported on the f-t-list last night), CTRL-S works fine,
so it looks like the problem is clicking on the icon.

1.9.104 should be in rawhide today.

Comment 7 Paul F. Johnson 2005-05-23 12:57:25 UTC
Looks like things are happy again in 1.9.104 on this one, but PDF export seems
to kill the software. Can someone please check this?

Comment 8 Caolan McNamara 2005-06-09 12:09:38 UTC
will be ok in >= 1.9.108-2

Comment 9 Paul F. Johnson 2005-06-09 12:14:14 UTC
ETA?

Comment 10 Caolan McNamara 2005-06-10 15:09:09 UTC
pushed fc4-updates/rawhide, whenever it shows up on mirrors


Note You need to log in before you can comment on or make changes to this bug.