Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155431 - Provisioning : url field from advanced options does not change after update
Summary: Provisioning : url field from advanced options does not change after update
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 370
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Clifford Perry
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 09:53 UTC by Nguyen Ngoc Can
Modified: 2007-07-31 15:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-17 15:18:47 UTC


Attachments (Terms of Use)

Description Nguyen Ngoc Can 2005-04-20 09:53:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
I test provisioning : in "Advanced options" i changed url : --url://<url of my satellite> to url : --url://<my rhn proxy> ... I would like that provisioning will pass by my rhn proxy 3.7 and not directly vy my satellite 3.7 ... But change has not taken effect ... url has not changed ...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. system -> kickstart -> profile -> options -> Advanced options
2. I changed "http://my-satellite-url/kickstart/dist/ks-rhel-i386-as-3/ to "http://my-rhn-proxy-url/kickstart/dist/ks-rhel-i386-as-3/"
3. click on update kickstart button
4. nothing has changed
  

Actual Results:  if url field is empty, it's ok, but if url field is not empty, so it will be all the time static value "http://my-satellite-url/kickstart/dist/ks-rhel-i386-as-3/" and not other else

Expected Results:  when clickin on update kickstart button, changes will be done for url field

Additional info:

Comment 3 Clifford Perry 2005-05-17 15:18:47 UTC
Correct - just going through this with a 3.7 Satellite with a 3.7 Proxy
registered to it. 

- register a system via the proxy to the Satellite
- click onto system and go to kickstart
- secnd screen has option :

Select RHN Proxy:  	

Choose either None or the RHN Proxy system you wish to kickstart through and
proceed. The kickstart profile will be automatically re-written when being sent
to the client with the RHN Proxy information rather than the Satellite server
url details. 

The bug as reported is not a true bug, but expected and correct behaviour. 

If you edit the kickstart URL in the advanced options, you by default will *not*
see the change when you go to view the kickstart profile within the webUI. this
is because this field is dynamically generated and puts in the URL of the
Satellite you typed within the web browser to view the kickstart profile, so use
hostname and you will see hostname listed, use IP address and see IP address
listed. 

Examples:
rlx-1-14 = RHN Proxy 3.7
rlx-1-24 = RHN Satellite 3.7

Type in browser:
https://rlx-1-24.rhndev.redhat.com/kickstart/ks/label/rhel4-as-gold

See:
url --url http://rlx-1-24.rhndev.redhat.com/ty/hMUZWMzn

Type in browser (IP of rlx-1-24):
https://192.168.36.124/kickstart/ks/label/rhel4-as-gold

See:
url --url http://192.168.36.124/ty/RjqvTOTT

Type in browser:
https://rlx-1-14.rhndev.redhat.com/kickstart/ks/label/rhel4-as-gold

See:
url --url http://rlx-1-14.rhndev.redhat.com/ty/0ky3qhOY

- the rhn proxy forwarded the request to the Satellite to get the kickstart
profile and it was written and presented with the kickstart file with the url as
the RHN Proxy system by the Satellite, given back to the proxy apache to present
to the requester. 

Hopefully this all makes sense. let me know if you got anything else. 

Cliff. 


Note You need to log in before you can comment on or make changes to this bug.