Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155430 - RHEL4: mount is unable to mount by label with multiple active paths to a device
Summary: RHEL4: mount is unable to mount by label with multiple active paths to a device
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-04-20 09:50 UTC by Karel Zak
Modified: 2013-10-31 05:44 UTC (History)
3 users (show)

Fixed In Version: RHBA-2005-669
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 16:52:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:669 qe-ready SHIPPED_LIVE util-linux bug fix update 2005-10-05 04:00:00 UTC

Description Karel Zak 2005-04-20 09:50:28 UTC
+++ This bug was initially created as a clone of Bug #116300 +++

Description of problem:
The new version of the mount command (mount-2.11y-31.1) 
checks /proc/partitions for duplicate listings of devices containing 
the same label. If multiple labels do exist, the mount will fail. 

from mount_one() in mount.c
nspec = get_spec_by_volume_label(spec+6);
if (nspec)
nspec2 = second_occurrence_of_vol_label(spec+6);
if (nspec2) {
if (verbose)
printf(_("mount: the label %s occurs on "
"both %s and %s\n"),
spec+6, nspec, nspec2);
die (EX_FAIL,
_("mount: %s duplicate - not mounted"),
spec, _PATH_FSTAB);
}

With PowerPath, there are multiple active paths to the same LUN.  
Since there are multiple active paths, the new version of mount does 
not allow the devices to be mounted by label.  
Request to modify this to allow for mounting of PowerPath devices by 
label.

Comment 8 Karel Zak 2005-09-12 15:13:35 UTC
*** Bug 168100 has been marked as a duplicate of this bug. ***

Comment 11 Red Hat Bugzilla 2005-10-05 16:52:44 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-669.html


Comment 13 Mark Bradbury 2005-11-17 11:10:18 UTC
This also happens in AS 3 is there going to be a ERRATA released for AS 3 aswell ?

Comment 14 Karel Zak 2005-11-18 10:24:29 UTC
Yes. Fixed also in RHEL3-U6. See bug #116300 and Errata 2005:626.


Note You need to log in before you can comment on or make changes to this bug.