Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155429 - Both chinese in anaconda does not have correct fonts
Summary: Both chinese in anaconda does not have correct fonts
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 09:09 UTC by Leon Ho
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-29 01:16:37 UTC


Attachments (Terms of Use)
screenshot (deleted)
2005-04-20 09:10 UTC, Leon Ho
no flags Details

Description Leon Ho 2005-04-20 09:09:51 UTC
Description of problem:
Both chinese in anaconda does not have correct fonts. It seems that some of the
glyphs are coming from japanese font.

Version-Release number of selected component (if applicable):
anaconda-10.2.0.51-1

How reproducible:
everytime

Steps to Reproduce:
1. Install
2. Use simplified or traditional chinese

Comment 1 Leon Ho 2005-04-20 09:10:23 UTC
Created attachment 113398 [details]
screenshot

Comment 2 Peter Jones 2005-04-20 18:37:57 UTC
OK, so either the translations are wrong, as these look like what's in the po
file, or the actual font is wrong.  I have no idea what to do about either of
those, but I suspect you do.  Thoughts?

Comment 3 Jeremy Katz 2005-04-20 18:40:56 UTC
I'm guessing the font is missing.  Look in /usr/share/fonts (in stage2.img) and
see if the chinese fonts are there.  It's entirely possible with the fun of
fonts moving around, we missed one. 

Comment 4 Leon Ho 2005-04-21 00:27:31 UTC
For your question in IRC on fonts - The heavier one is japanese fonts - Kochi
Mincho. The lighter one should be the correct one - AR PL SungtiL GB. 

You see the help title (four characters) - First, Second, Forth look like they
are using japanese fonts, and third one is using simplified chinese glyph.

It seems like a effect of having Japanese preferred first.

Comment 5 Wei-Lun Chao 2005-04-21 06:06:21 UTC
There was the same problem in FC2.
FC3 has fixed it, but it comes out in FC4T2 again.


Comment 6 Jeremy Katz 2005-04-27 21:15:06 UTC
It looks like rawhide has traditional working fine, but not simplified.  We have
both gbsn00lp.ttf and bsmi00lp.ttf in the stage2.img.  Which _should_ be right
unless we need AR PL Kaitim GB for some reason for those characters.  Kochi
Mincho is listed first in /etc/fonts/fonts.conf, but the right thing should
happen with LANG set.

I'd rather not add the other font -- is it actually needed or is there something
else going on?

Comment 7 Leon Ho 2005-04-28 04:11:11 UTC
Something else is going on... AR PL SungtiL GB should be enough for those chars
in simplified chinese.

Is the LANG set to zh_CN.UTF-8?

Tagoh-san, any insight?


Comment 8 Leon Ho 2005-04-28 04:12:15 UTC
(this problem maybe hidden for a while as we have just removed bitmap and move
back to ttf on this devel cycle)

Comment 9 Akira TAGOH 2005-04-28 04:30:00 UTC
BTW which LANG is anaconda running on? it's probably because fontconfig chooses
the Japanese font first so that the proper LANG isn't set and basically some
kanji characters are duplicated between Chinese font and Japanese font. 
fontconfig won't work without the proper LANG in all CJK AFAICS. otherwise it
just works for one or two.

Comment 10 Chris Lumens 2005-04-28 13:41:30 UTC
LANG is set to zh_CN.UTF-8 by the loader.

Just thought I'd throw in that there may be further problems here regarding
Chinese.  We've noticed that the button bar is never being translated and gtk
complains about the locale not being supported by the C library, despite the
above LANG setting.  Perhaps these two issues are related.

Comment 11 Akira TAGOH 2005-04-28 13:59:59 UTC
Oh, this problem is surely because of that. the proper fonts won't be chosen so
that gtk+ doesn't recognize the locale. no zh_CN.UTF-8 locale are available
somehow? just wonder.

Comment 12 Jeremy Katz 2005-04-28 16:44:52 UTC
Yeah, I was just going to say that there's probably a relationship there.  I'm
going to be poking into that more later today hopefully... any insight would help


Comment 13 Jeremy Katz 2005-04-29 01:16:37 UTC
This looks better to me in /mnt/redhat/devel/katzj/i386 (which should be in
rawhide-20050429)


Note You need to log in before you can comment on or make changes to this bug.