Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155424 - Never managed to get NetworkManager working with an encrypted network
Summary: Never managed to get NetworkManager working with an encrypted network
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 07:37 UTC by Christian Schaller
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-21 09:10:50 UTC


Attachments (Terms of Use)

Description Christian Schaller 2005-04-20 07:37:08 UTC
I have never (FC3 or now F4 test2) managed to get NetworkManager to connect to a
network using an encryption key. I have tried just entering it 'straight' and by
using the 0x prefix that system-config-network uses. I am able to connect with
system-config-network, but with NetworkManager it have never succeeded. If there
are any logfiles etc. I can provide to help debug this let me know.

Comment 1 Ryan Skadberg 2005-04-20 22:28:44 UTC
Christian - Have you tried using the passphrase instead of that actual key? 
That's what is supposed to go in.

Comment 2 jeroen 2005-04-21 07:44:26 UTC
Try having a terminal open with "tail -f /var/log/messages" while you attempt to
connect to an encrypted network. It'll give you a lot more information about
what NM is doing.

I also had problem until i realised i had to use the "ASCII key" option for my
encrypted airport extreme AP.

Comment 3 Christian Schaller 2005-04-21 09:01:07 UTC
Ryan, there is no passphrase, our wifi router just lets us choose from a list of
keys.

Jeroen, I am going too attach a var/log/messages output to this bugzilla. As we
are able to connect with system-config-network I assume our router don't need
re-configuration.

Comment 4 Christian Schaller 2005-04-21 09:10:50 UTC
Closing this bug as I noticed it was just me never realizing I could change the
type of key to be entered. Seems my problem was exactly the same as Jeroen's. 
Should be message saying you need the 0x prefix though (or better, not need the
0x prefix)


Note You need to log in before you can comment on or make changes to this bug.