Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155416 - virtual consoles are invisible on i855/i865 chipset
Summary: virtual consoles are invisible on i855/i865 chipset
Keywords:
Status: CLOSED DUPLICATE of bug 161242
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-20 07:20 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-30 05:04:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 3094 None None None Never

Description Jens Petersen 2005-04-20 07:20:28 UTC
Description of problem:
With rawhide trees for a while now, the virtual consoles are
just blank screens for me.

How reproducible:
every time

Steps to Reproduce:
1. Install rawhide on Dell Dimension 2400C.
2. After booting, press Alt-Ctrl-F1
  
Actual results:
Blank dark screen.

Expected results:
Fedora Core blah blah
Login: prompt

Additional info:
dmesg includes:
agpgart: Detected an Intel 865 Chipset.
agpgart: Detected 8060K stolen memory.
agpgart: AGP aperture is 128M @ 0xe8000000

Comment 1 Dave Jones 2005-04-20 07:31:31 UTC
hmm, you get kernel boot text before rhgb/X starts up though right ?

do you have any vga= or video= lines in your boot options ?
If so, can you try booting without them ?


Comment 2 Colin Charles 2005-04-20 07:31:56 UTC
Happens on the i855 chipset too (on a thinkpad r51)

agpgart: Detected an Intel 855 Chipset.
agpgart: Detected 8060K stolen memory.
agpgart: AGP aperture is 128M @ 0xe0000000

The only thing that works for me is vt7 (X)

Comment 3 Colin Charles 2005-04-20 07:33:49 UTC
Dave, as per comment #1, yes, before X starts up, I see a console. And I have no
video= or vga= lines in the boot options... But after X is started, all my vt1-6
is invisible.

Comment 4 Dave Jones 2005-04-20 07:41:48 UTC
can you comment out the Load "dri" in your /etc/X11/xorg.conf and see if that
'fixes' it ?



Comment 5 Colin Charles 2005-04-20 16:00:30 UTC
davej, commenting out the load "dri" section didn't work, and give me back my
consoles

Comment 6 Jens Petersen 2005-04-21 00:04:28 UTC
Dave, I'm using my testbox for development work currently, so I don't think 
I'll be able to reboot for the rest this week I'm afraid.

Colin, to clarify: commenting out dri helped or didn't help? :)

Comment 7 Colin Charles 2005-04-21 01:05:28 UTC
Didn't help, no. 

Would gladly talk to davej on irc and try and get this sorted even...

Comment 8 Colin Charles 2005-04-21 23:40:25 UTC
Is this like bug #153729? Sure I don't get the green border (but thats mga -
https://bugs.freedesktop.org/show_bug.cgi?id=2991), but we're definitely seeing
the i810 funnies that dmalcolm has reported
(https://bugs.freedesktop.org/show_bug.cgi?id=3094)

Comment 9 Stephen Murray 2005-06-15 20:43:57 UTC
I am seeing the same problem on FC4 in runlevel=5. This was not a issue with
FC3, kept very current via up2date. Machine is Dell 4600, dmesg shows this for
AGP chipset:

Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected an Intel 865 Chipset.
agpgart: Detected 892K stolen memory.
agpgart: AGP aperture is 128M @ 0xe8000000

I commenting out DRI in xorg.conf and rebooted, it had no effect. 

Killing off getty for tty/1, thus forcing a restart of getty, had no effect.

Coming up in runlevel=3 shows all virtual consoles, no problem.

Issuing "init 3" from within GUI does not bring back the virtual consoles.

Comment 10 Vincenzo Ciancia 2005-06-20 16:12:52 UTC
I also have this problem with fc4 on a i855 card, and had no problem both with
fc3 and ubuntu 5.04 which has both xorg 6.8.2 and kernel 2.6.11. Is there
anything I could do to help identifying the problem?

Comment 11 Tauroka 2005-06-29 07:54:26 UTC
"Me Too"

i855GM in a Fujitsu (Siemens) P7010.
Worked fine in FC3.
Same problem as described in FC4.

Solution:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

Normal behaviour since copying Mike Harris's FC3 libvgahw.a over the top of the
FC4 one.

Recommend that this bug be marked as a duplicate of Bug #161242

Comment 12 Mike A. Harris 2005-06-29 20:16:33 UTC
Jens:  Please review bug #161242, and confirm wether or not the workaround
provided in that bug report resolves the issue for you.  If it does, please
reassign this bug to xorg-x11, and mark it as a duplicate of bug #161242.

Comment 13 Jens Petersen 2005-06-30 05:04:52 UTC
Thanks, Mike.  I installed the module from xorg-x11-6.8.1-12.FC3.21
and yes this fixed the problem for me. :)

I also noticed that after logging out of X now, gdm comes up noticeably
quicker than before fwiw.

*** This bug has been marked as a duplicate of 161242 ***


Note You need to log in before you can comment on or make changes to this bug.