Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155353 - Firefox doesn't open MS Word documents in OpenOffice.org
Summary: Firefox doesn't open MS Word documents in OpenOffice.org
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-19 14:23 UTC by Kjartan Maraas
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-20 17:34:08 UTC


Attachments (Terms of Use)

Description Kjartan Maraas 2005-04-19 14:23:11 UTC
Description of problem:

I'm clicking on a link in our internal webmail solution and get a dialog saying
"You have chosen to open 'some long filename with spaces.doc' which is a: DOC
file from servername.domain.com. What should firefox do with this file"

And it suggests no handler for the file, just prompts to save it. This could
very well be a generic MIME problem, but then you can move it to the correct
product :-)

I tried the same on Windows in Internet Explorer and it worked ok there.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fridrich Strba 2005-05-20 08:18:45 UTC
This is a problem with the *.desktop file names missmatch between
openoffice.org-* packages and shared-mime-info package. Shared-mime-info is
expecting redhat-{word-processor,spreadsheet,presentations,drawing}.desktop, but
openoffice.org-* packages provide
openoffice.org-1.9-{base,calc,draw,impress,math,writer}.desktop. Since the
defaults are not present, the first application in alphabetical order that
supports the give mimetype is used. For every wordprocessing document, but the
oasis formats, gnome-abiword.desktop is used, since it is alphabetically before
openoffice.org-1.9*.desktop.
There are two possible solutions:
(1) in /usr/share/applications/defaults.list, replace the occurences
redhat-*.desktop with corresponding openoffice.org-1.9*.desktop;
(2) modify the openoffice.org packages the way that openoffice.org-1.9*.desktop
get renamed during the rpmbuild process in redhat-*.desktop and packaged as such.
Logically, I think that the second solution is the good one. I will ping caolanm
when he is back suggesting him a patch.
BTW: in shared-mime-info the application/vnd.wordperfect mimetype should be
handled by default by openoffice.org. Although using the same library as
abiword, the openoffice.org WordPerfect importer supports more features (correct
conversion of all tables, page form, orientation ...).

Comment 2 Dan Williams 2005-05-20 17:34:08 UTC
should be fixed in shared-mime-info-0.16-3 which should come out tomorrow

Solution is #1 after talking with jrb.  I also made OOo the default for
WordPerfect documents, as we Abiword is in Extras, not Core.


Note You need to log in before you can comment on or make changes to this bug.