Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155349 - xfs initscript issuing errors at firstboot
Summary: xfs initscript issuing errors at firstboot
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xfs
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-04-19 13:33 UTC by Florian La Roche
Modified: 2008-06-14 14:07 UTC (History)
1 user (show)

Fixed In Version: 6.8.2-31.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-14 14:07:26 UTC


Attachments (Terms of Use)
The error message from xfs initscript (deleted)
2005-05-03 12:38 UTC, Ngo Than
no flags Details | Diff

Description Florian La Roche 2005-04-19 13:33:57 UTC
Description of problem:


Installing current FC-devel and booting the first time gives warnings.

This patch resolves the issue:
--- xfs.init    6 Apr 2005 23:11:51 -0000       1.19
+++ xfs.init    19 Apr 2005 13:29:47 -0000
@@ -36,7 +36,7 @@ buildfontlist() {
          # If fonts.dir does not exist, or if there are files in the
          # directory with a newer change time, regenerate fonts.dir, etc.
          # Using "-cnewer" here fixes bug #53737
-         if [ ! -e fonts.dir -o -n "$(find . -maxdepth 1 -type f -cnewer
fonts.dir -not -name 'fonts.cache*')" ]; then
+         if [ ! -e fonts.dir -o -n "$(find . -maxdepth 1 -type f -cnewer
fonts.dir -not -name 'fonts.cache*' 2>/dev/null)" ]; then
             rm -f fonts.dir
             if ls | grep -iqs '\.ot[cf]$' ; then
                # Opentype fonts found, generate fonts.scale and fonts.dir





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mike A. Harris 2005-04-19 14:27:26 UTC
What warnings?

Comment 2 Mike A. Harris 2005-04-19 14:29:08 UTC
Also, what version of xorg-x11 is installed?

Comment 3 Florian La Roche 2005-04-19 15:12:36 UTC
This was newest FC-devel from last week, should also happen with
newest FC4test release.

Error message came from the xfs init script and from find.
Must have been something like "file not found" or similar.



Comment 4 Mike A. Harris 2005-04-19 16:01:12 UTC
"newest from last week" doesn't mean anything.  There was a bug in the
script which we fixed and it's getting several dupes now.  I am wondering
if this is a dupe of that or something else.  I want to know what the
exact error and problem is, so I am sure that we're fixing it the
best way.

Redirecting to /dev/null, just hides the symptoms and may not fix
the underlying problem depending on what the problem is.  I can't make
that judgement without more information though.

I'll leave this here for now.  Please supply the details if you can
reproduce it again.

Comment 6 Ngo Than 2005-05-03 12:38:12 UTC
Created attachment 113960 [details]
The error message from xfs initscript

i can reproduce it every time on my machine by boot process

The error message from xfs initscript: 

 find: fonts.dir: No such file or directory

The problem will always happen if the file fonts.dir does not exist in search
directory.

Comment 7 Ngo Than 2005-05-03 12:40:03 UTC
the attached patch should fix this problem

Comment 8 Bill Nottingham 2005-05-21 03:34:44 UTC
fixed in 31.1/32.

Comment 9 Mike A. Harris 2005-05-24 10:39:18 UTC
Built in rawhide as 6.8.2-34

Comment 10 Florian La Roche 2005-10-16 20:05:36 UTC
This seems still to happen with current FC-development trees. Maybe the
patch from Than Ngo should still be applied?

Thanks,

Florian La Roche


Comment 12 Mike A. Harris 2006-02-05 22:14:05 UTC
Fixed in CVS, and will appear in rawhide during the upcoming mass rebuild.



Note You need to log in before you can comment on or make changes to this bug.