Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155347 - Importing vcf, doesn't know about groups in vcf
Summary: Importing vcf, doesn't know about groups in vcf
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-19 13:16 UTC by Michael A. Peters
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-19 16:22:13 UTC


Attachments (Terms of Use)

Description Michael A. Peters 2005-04-19 13:16:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
Back in the Evo 1.x days I used evolution and added categories for the contact manager - such as Friends, E-MAIL List, etc.

Then I stopped using evolution and started using balsa due to crashes - carrying over the same vcf address book.

I've started using Evo 2.2.2 which has demonstrated to me to be extremely stable in rawhide, and balsa is no longer in rawhide. So this morning I used Evolutions import feature to import the .vcf file.

It worked quite well, the categories I had assigned were still there - but for addresses I had added in Balsa, I couldn't add them easily to these custom categories because they did not show up in the groups list - the import didn't make sure all groups that were in the imported vcf were known to evolution for adding contacts to those categories.

Version-Release number of selected component (if applicable):
evolution-2.2.2-1

How reproducible:
Always

Steps to Reproduce:
1. create .vcf address book containing categories not in Evolutions defaults
2. import vcf
3. see that the address book knows the category, but that category doesn't show up when you wish to add another contact to that category
  

Actual Results:  The category isn't in the selectable catagories for quick adding

Expected Results:  during import, any categories not know to evolution should be added to the categories that you can easily add contacts to.

Additional info:

Comment 1 Dave Malcolm 2005-04-19 16:22:13 UTC
Thanks for the bug report.  

A quick workaround may be to use gconf-editor (or gconftool-2) to edit this
GConf key: /apps/evolution/general/category_master_list

At the moment, the Fedora developers don't have
time to work on this particular issue. The best way to make sure your problem
will get looked on is to report it to the authors of the program. Most 
upstream authors use a bug tracking system like bugzilla, and more people
who know the code will be looking at the bug report there.

The upstream bug tracking system to use is:
http://bugzilla.gnome.org/

Please make sure the bug isn't already in the upstream bug tracker before
filing it.




Note You need to log in before you can comment on or make changes to this bug.