Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155341 - MySQL-python-1.0.0 is not compatible with MySQL 4.1
Summary: MySQL-python-1.0.0 is not compatible with MySQL 4.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: MySQL-python
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tom Lane
QA Contact:
URL:
Whiteboard: RHEL4U3NAK
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-19 10:27 UTC by Gavrie Philipson
Modified: 2013-07-03 03:05 UTC (History)
5 users (show)

Fixed In Version: RHBA-2007-0295
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-08 00:25:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0295 normal SHIPPED_LIVE MySQL-python bug fix update 2007-04-28 18:36:54 UTC

Description Gavrie Philipson 2005-04-19 10:27:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
The version of MySQL-python that is installed with RHEL4 does not match the version of MySQL that installed.
According to the developers of MySQL-python, to support MySQL 4.1, at least MySQL-python-1.2 is needed. Upgrading manually to that version solves the problem.

As mentioned in http://sourceforge.net/project/shownotes.php?release_id=243731, "MySQL-4.1 is not yet supported".

Version-Release number of selected component (if applicable):
MySQL-python-1.0.0-1

How reproducible:
Always

Steps to Reproduce:
bash$ python
Python 2.3.4 (#1, Feb 22 2005, 04:09:37)
[GCC 3.4.3 20041212 (Red Hat 3.4.3-9.EL4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import MySQLdb
>>> import MySQLdb.cursors
>>> mysql_con = MySQLdb.connect(host='localhost', user='bugs', passwd='bugs', db='bugs', cursorclass=MySQLdb.cursors.DictCursor, compress=1)
>>> mysql_cur = mysql_con.cursor()
>>> mysql_cur.execute("select * from bugs")
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.3/site-packages/MySQLdb/cursors.py", line 95, in execute
    return self._execute(query, args)
  File "/usr/lib/python2.3/site-packages/MySQLdb/cursors.py", line 114, in _execute
    self.errorhandler(self, exc, value)
  File "/usr/lib/python2.3/site-packages/MySQLdb/connections.py", line 33, in defaulterrorhandler
    raise errorclass, errorvalue
ValueError: invalid literal for int(): 1-


Actual Results:  An exception was encountered instead of the correct result.

Expected Results:  The data should have been returned correctly.

Additional info:

Using the upgraded python-MySQL-1.2 package, the query works as expected.

Comment 1 Tom Lane 2005-04-19 16:26:52 UTC
OK, I'll try to get the update into Fedora Core 4 and RHEL4 U2.

Comment 6 Tom Lane 2005-08-29 14:54:03 UTC
Switching back to ASSIGNED state because the fix was postponed till U3.

Comment 10 Matt Hyclak 2006-02-04 15:31:45 UTC
Is this still planned for U3? It doesn't seem to be in the beta packages yet.

Comment 11 Tom Lane 2006-02-04 19:11:17 UTC
Afraid not --- it's slipped to U4.  (I'm not happy about this either, but there
are only so many packages that QA can deal with per update, and this fix didn't
make the cut.)

Comment 12 Matt Hyclak 2006-02-04 19:16:19 UTC
Hmm, that's disappointing. I rebuilt the FC4 RPM, but there seems to be a memory
leak somewhere. I guess I'll just keep waiting patiently or maybe get brave
enough to try release candidates :-)

Comment 15 Gary Wilson 2006-05-18 20:08:43 UTC
Is there a timeframe for when this will be fixed? It has been over a year now :(

Comment 16 Tom Lane 2006-05-18 20:36:10 UTC
The right way to get the priority of this problem raised is to pester Red Hat
support and get them to open an issue tracker for it.  I'm at the wrong end of
the food chain to have any leverage over which packages get updated in RHEL
updates ...

Comment 19 Daniel Riek 2006-09-05 16:44:44 UTC
The component of this request is planned to be updated in Red Hat enterprise
Linux 4.5.

This enhancement request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux maintenance release.

Product Management has requested further review of this request by Red Hat
Engineering, for potential inclusion in a Red Hat Enterprise Linux Update
release for currently deployed products.

This request is not yet committed for inclusion in an Update release. 

Comment 23 Red Hat Bugzilla 2007-05-08 00:25:10 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0295.html


Note You need to log in before you can comment on or make changes to this bug.