Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155337 - Error messages from find when starting xfs
Summary: Error messages from find when starting xfs
Keywords:
Status: CLOSED DUPLICATE of bug 154056
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-19 09:40 UTC by Göran Uddeborg
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-19 10:19:03 UTC


Attachments (Terms of Use)

Description Göran Uddeborg 2005-04-19 09:40:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050309 Fedora/1.7.6-0.cvs.20050309

Description of problem:
When booting (and not hiding things with a graphical boot) there comes error messages from find when starting xfs.  In C locale, they read like this:

find: warning: you have specified the -maxdepth option after a non-option argument -type, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.

Version-Release number of selected component (if applicable):
xorg-x11-xfs-6.8.2-19

How reproducible:
Always

Steps to Reproduce:
1. Boot, looking at the messages

Additional info:

Line 39 in the xfs init script reads

         if [ ! -e fonts.dir -o -n "$(find . -type f -maxdepth 1 -cnewer fonts.dir -not -name 'fonts.cache*')" ]; then

Obviously, the fix is to put "-maxdepth 1" before "-type f".

Comment 1 Mike A. Harris 2005-04-19 10:19:03 UTC

*** This bug has been marked as a duplicate of 154056 ***

Comment 2 Göran Uddeborg 2005-04-19 11:35:24 UTC
Ah, I missed to include "devel" in the versions I searched in, before I filed my
own bug.


Note You need to log in before you can comment on or make changes to this bug.