Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155323 - Duplex not working on HP Lasterjet 2300
Summary: Duplex not working on HP Lasterjet 2300
Keywords:
Status: CLOSED DUPLICATE of bug 151645
Alias: None
Product: Fedora
Classification: Fedora
Component: foomatic
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-19 07:56 UTC by Dennis Björklund
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-20 14:06:03 UTC


Attachments (Terms of Use)

Description Dennis Björklund 2005-04-19 07:56:16 UTC
Description of problem:

Duplex printing does not work on HP Lasterjet 2300 using the latest upgrade of
foomatic for FC3. The original version works fine.

Version-Release number of selected component (if applicable):

works:       foomatic-3.0.2-3.i386.rpm
do not work: foomatic-3.0.2-13.3.i386.rpm

How reproducible:

Always

Steps to Reproduce:

1. Start system-config-printer-gui
2. Select the printer (laserjet 2300)
3. Select menu "Test->Duplex test"
  
Actual results:

2 pages printed

Expected results:

1 page printed with text on both sides, aka duplex printing :-)

Additional info:

The printer is configured to use postscript 3.

Comment 1 Tim Waugh 2005-04-19 15:34:48 UTC
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=113038

Please save this attachment and copy it to:

  /usr/share/foomatic/db/source/driver/Postscript.xml

Does this solve the problem?

Comment 2 Tim Niemueller 2005-04-19 16:34:11 UTC
The same here for an HP 4200dtn, duplex printing is not working. The duplex test
prints two pages instead of one. If works if I reinstall the original foomatic
version that came with the FC3 release.

# rpm -q foomatic
foomatic-3.0.2-13.3

The changed Postscript.xml file does not cure the problem for me.

Comment 3 Tim Waugh 2005-04-19 16:35:20 UTC
I forgot to mention: after copying the file, please rebuild the queues using
this command as root:

/usr/sbin/printconf-backend --force-rebuild

Does the problem still persist?

Comment 4 Tim Niemueller 2005-04-19 16:41:59 UTC
Copying the file and calling the rebuild fixes the problem. Thanks!

Comment 5 Dennis Björklund 2005-04-20 06:43:34 UTC
That solved it for me as well. Great!

Comment 6 Tim Waugh 2005-04-20 14:06:03 UTC

*** This bug has been marked as a duplicate of 151645 ***


Note You need to log in before you can comment on or make changes to this bug.