Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155322 - httpd start [FAILED]
Summary: httpd start [FAILED]
Keywords:
Status: CLOSED DUPLICATE of bug 155321
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-19 07:22 UTC by Nicholas Williams
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-19 07:27:39 UTC


Attachments (Terms of Use)

Description Nicholas Williams 2005-04-19 07:22:10 UTC
Description of problem:
When trying to start httpd from system services panel, I get "Start service httpd [FAILED]" which doesn't 
tell me very much at all. If, however, I restart, I get a very detailed message on services starting which 
tells me why starting httpd is failing. I had to restart several times to get it, as the message flash past 
FAST, but this is the jist of it:

Syntax error on line 6 of php.conf ... error while loading module /etc/httpd/modules/libphp5.so ... 
permission denied

Running "/etc/init.d/httpd start" from the command line returns only

Starting httpd:...............................................[FAILED]

libphp4.so exists, commenting out "LoadModule libphp5.so" on line 6 of php.conf doesn't do any good 
because php won't load, which means Apache won't load. I suspect disabling php5 would allow Apache 
to start, but my entire website revolves around php. Help?

Version-Release number of selected component (if applicable):
Apache 2.0.52-?
PHP-5.0.4.x
MySQL 4.1.1.3x

How reproducible:
Made no changes to system. This happens directly after install.

Steps to Reproduce:
Install fc4test2 with Apache, php, and mysql enabled
  
Actual results:
Apache won't start

Expected results:
Apache should start... I can't serve my website elsewise. I can do everything else from FTP to mail to 
use WebMin, but I can't get Apache to start

Additional info:
Since I manage my site remotely, I don't have access to the paper that I wrote the exact error message 
down on. That is all I can remember from memory. It is accurate, but there are parts left out. I will post 
those parts tomorrow when I can call my family and get someone to read the error to me.

Comment 1 Nicholas Williams 2005-04-19 07:27:39 UTC

*** This bug has been marked as a duplicate of 155321 ***


Note You need to log in before you can comment on or make changes to this bug.