Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155321 - httpd start [FAILED]
Summary: httpd start [FAILED]
Keywords:
Status: CLOSED DUPLICATE of bug 154195
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
: 155322 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-19 07:19 UTC by Nicholas Williams
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-19 07:49:30 UTC


Attachments (Terms of Use)

Description Nicholas Williams 2005-04-19 07:19:35 UTC
Description of problem:
When trying to start httpd from system services panel, I get "Start service httpd [FAILED]" which doesn't 
tell me very much at all. If, however, I restart, I get a very detailed message on services starting which 
tells me why starting httpd is failing. I had to restart several times to get it, as the message flash past 
FAST, but this is the jist of it:

Syntax error on line 6 of php.conf ... error while loading module /etc/httpd/modules/libphp5.so ... 
permission denied

Running "/etc/init.d/httpd start" from the command line returns only

Starting httpd:...............................................[FAILED]

libphp4.so exists, commenting out "LoadModule libphp5.so" on line 6 of php.conf doesn't do any good 
because php won't load, which means Apache won't load. I suspect disabling php5 would allow Apache 
to start, but my entire website revolves around php. Help?

Version-Release number of selected component (if applicable):
Apache 2.0.52-?
PHP-5.0.4.x
MySQL 4.1.1.3x

How reproducible:
Made no changes to system. This happens directly after install.

Steps to Reproduce:
Install fc4test2 with Apache, php, and mysql enabled
  
Actual results:
Apache won't start

Expected results:
Apache should start... I can't serve my website elsewise. I can do everything else from FTP to mail to 
use WebMin, but I can't get Apache to start

Additional info:
Since I manage my site remotely, I don't have access to the paper that I wrote the exact error message 
down on. That is all I can remember from memory. It is accurate, but there are parts left out. I will post 
those parts tomorrow when I can call my family and get someone to read the error to me.

Comment 1 Nicholas Williams 2005-04-19 07:24:48 UTC
my original post: "...libphp4.so exists, commenting..." SHOULD read: "...libphp5.so exists, 
commenting..."

Comment 2 Nicholas Williams 2005-04-19 07:27:44 UTC
*** Bug 155322 has been marked as a duplicate of this bug. ***

Comment 3 Joe Orton 2005-04-19 07:32:42 UTC
Disable httpd SELinux transition or upgrade to the Raw Hide php package; 

# setsebool httpd_disable_trans=1
# service httpd start

should work.


*** This bug has been marked as a duplicate of 154195 ***

Comment 4 Nicholas Williams 2005-04-19 07:38:28 UTC
[root@externalServer ~]# setsebool httpd_disable_trans=1
[root@externalServer ~]# service httpd start
Starting httpd: Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /etc/httpd/modules/libphp5.so into server: /etc/httpd/modules/libphp5.so: cannot 
restore segment prot after reloc: Permission denied
                                                           [FAILED]
[root@externalServer ~]# 

That is the exact error I got when it tries to start on restart. I just never got the error (only "[FAILED]") 
when running it through the command until I ran "[root@externalServer ~]# setsebool 
httpd_disable_trans=1".

So hmmm... didn't work... I'm sure this is simple and I'm just missing it somehow.

Comment 5 Nicholas Williams 2005-04-19 07:42:24 UTC
I also get the

[root@externalServer ~]# /etc/httpd/modules/libphp5.so
Segmentation fault

that he was talking about in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154195

Comment 6 Joe Orton 2005-04-19 07:49:30 UTC
Hrm, that should work.  But upgrading to the Raw Hide php is the proper
solution, anyway.   (And no, you can't exec a shared library, that's not very
surprising)

*** This bug has been marked as a duplicate of 154195 ***

Comment 7 Nicholas Williams 2005-04-19 07:57:45 UTC
Forgive my naivety... but how would I go about upgrading / downloading the upgrade to Raw Hide php? 
Simply pointing me to the website will be quite adequate... don't worry about trying to explain it. I 
Googled it and Bugzilla'd it real quick, but didn't find anything I understood. I'm still relatively new to 
the Linux circle...I had to move on because I've exhausted my Windows and Macintosh training ;)

Comment 8 Joe Orton 2005-04-19 08:00:35 UTC
Simply running "yum update php" should work from an FC4test2 install, I think.

Otherwise download all the php RPMs from:

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

and rpm -Uvh php*.rpm them.


Note You need to log in before you can comment on or make changes to this bug.