Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155296 - Editing user in your account strips roles
Summary: Editing user in your account strips roles
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D
Version: RHN Devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Bowman
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: rhnMilestone1
TreeView+ depends on / blocked
 
Reported: 2005-04-18 20:18 UTC by Ken Ganong
Modified: 2007-04-18 17:23 UTC (History)
1 user (show)

Fixed In Version: rhn400
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 20:55:16 UTC


Attachments (Terms of Use)

Description Ken Ganong 2005-04-18 20:18:03 UTC
Description of problem:
Editing user in your account strips roles

Steps to Reproduce:
1. Log-in
2. Click my account and change a single field.
3. Click the submit button
  
Actual results: (normal user)  !!

Expected results: the roles of the past

Comment 1 Michael Bowman 2005-04-20 18:35:03 UTC
Refactored our Actions for this. Basically, the problem was that we were calling
the same action for both self editing and when an admin edits an account. For
the self editing we don't edit roles, therefore our action gets null for the new
role set. For the admin editing action, we weren't ever removing roles from a
user. When I fixed this, the self edit broke because the action didn't know if
it got null because the user wasn't allowed to select any roles, or because all
roles had been removed.

We now have two actions with the commonality factored out into a helper class.

Comment 2 Jesus M. Rodriguez 2005-09-28 20:55:16 UTC
Verified, closing.


Note You need to log in before you can comment on or make changes to this bug.