Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 155293 - man 5 nfs should include vers as a mount option
Summary: man 5 nfs should include vers as a mount option
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-18 20:00 UTC by zoratu
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 10:56:53 UTC


Attachments (Terms of Use)

Description zoratu 2005-04-18 20:00:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
The source seems to indicate (util-linux/mount/nfsmount.c):

                        else if (!strcmp(opt, "nfsvers") ||
                                 !strcmp(opt, "vers"))
                                nfsvers = val;

'vers' and 'nfsvers' are acceptable, since Linux has had to support vers= from the beginning to be compatible with other platforms, and likely always will.  It would be informative if 'vers' was mentioned as usable on the manual page, and folks didn't have to look in the source to find it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. man 5 nfs


Actual Results:  man 5 nfs currently says about NFS version options:
       nfsvers=n      Use  an  alternate RPC version number to contact the NFS
                      daemon on the remote host.  This option  is  useful  for
                      hosts  that  can  run multiple NFS servers.  The default
                      value is version 2.


Expected Results:  man 5 nfs ought to say about NFS version options:
       nfsvers=n      Use  an  alternate RPC version number to contact the NFS
                      daemon on the remote host.  This option  is  useful  for
                      hosts  that  can  run multiple NFS servers.  The default
                      value is version 2.
       vers=n         vers is an alternative to nfsvers and is compatible with
                      many other operating systems.


Additional info:


Note You need to log in before you can comment on or make changes to this bug.